coTURN and testing with Jitsi

Hi All,

I’m trying to setup a TURN server using coTURN and Prosody as discussed on https://github.com/jitsi/jitsi-meet/blob/master/doc/turn.md .

I’m wondering how I confirm that this configuration is working correctly as I can’t see any sessions occurring in the coTURN admin panel.

Cheers

If you have one jvb instance and you have the useStunTurn: true in the main section of the config, then add to jvb’s machine firewall rules to drop all connections from your client public address (if you have on the same machine nginx or any web server leave just port 443 allowed), this way you cannot establish a direct connection from that client to jvb and all traffic needs to go through the turn. Disable p2p for this test.

Another way to test this is to leave p2p enabled, but set the iceTransportPolicy to ‘relay’ in config.js (https://github.com/jitsi/jitsi-meet/blob/eeb0697e5219bcf7d408850838c23feeecbf7399/config.js#L322).

Wouldn’t JVB just revert to trying to use 443 when its using Jetty as its Webserver?