Copy meeting link does not work

Linux Mint 20.1 Cinnamon
Jitsi 2.4.2.

I recently started with Jitsi and like it.

However, when I want to invited people for meeting, the function “copy meeting link” does not work.

I tried additional pressed down keys and key combination but could not get the copy function working.

Additionally pressed down keys: ctrl, shift, alt, super and combinations of this keys.

How could the meeting link be copied into clipboard?

Thanks for helping comments!

Thanks for reporting we had fixed the problem upstream, we need to update jitsi-meet electron in order to fix it and there.

@ damencho

Thanks for your immediate reply!!!

I am a bloody newbie in this matter, thus not sure if I understand your kind reply correct.

Does it mean I need to install the latest version? ( I am hesitant to upgrade outside the Linux Mint repository.)
Can I also fix the problem by adding/deleting/modifying some lines in file? If so in which which file(s)?


Are you using the Jitsi Meet electron client or directly the browser?
Which deployment are you using? If you are using directly from the browser this is already fixed there.

Sorry for insufficient information.

I am NOT using Jitsi Meet in a browser.

I installed the application from the SW depository of Linux Mint, 20.1, Cinnamon. Is this called Jitsi Meet electron?

Looking at the Jitsi Download site, I would say that I am using the Desktop version.

I saw that in Firefox (v85.0) the copying of the link works.

You are complaining about a problem with jitsi-meet, you do not need a special desktop client for it, you just need to open the link in the browser.

You are confusing 2 different products, the original Jitsi desktop is a Java application used for direct connection between computers on the Internet; it has been discontinued by the Jitsi project and is only updated very rarely by volunteers.

The focus of the Jitsi project is now Jitsi-meet, a server application. It’s used primarily in browsers, and there is the electron application, that is using the Chrome engine to do a very thin embedding of a browser in a desktop application. As it’s an embedding, the code is not fully synchronous with a typical browser, but can lags a bit. As you are using a separate packaging done by a Linux distribution, it can even lags a bit behind the official Jitsi Electron packaging. So while everything globally works the same, some details can be fixed a bit later on Electron (and conversely sometimes regressions are not yet appearing in Electron…)

Thanks for all replies, I learned a bit more on Jitsi.

I solved my original problem just be upgrading to a higher version from the ubuntu repository.