Continuously facing "There is no active conference, not updating last N" when joining call from chrome on mobile

I am successfully able to connect to a video call (Jitsi IFrame) through chrome on the desktop. But when I connect to the same call using chrome on mobile, it fails.

I am loading IFrame from ‘meet.jit.si’. My application is using SSL certificate generated from LetsEncrypt.

See my logs of the mobile device below.

(TIME) index.html loaded:	 1010.6000000014901

2022-09-21T06:19:04.995Z [modules/browser/BrowserCapabilities.js] <new <anonymous>>:  This appears to be chrome, ver: 105.0.0.0

2022-09-21T06:19:05.032Z [modules/statistics/LocalStatsCollector.js] <tn.connectAudioContext>:  Connecting audio context

2022-09-21T06:19:08.635Z [features/base/redux] <Object.persistState>:  redux state persisted. ca7feb322e2dfe4d7efaeb81d86690b7 -> 35a9c605a5e0c071c055eec735cd8161

2022-09-21T06:19:09.284Z [features/base/config] Extending config with: {"buttonsWithNotifyClick":["hangup"],"connectionIndicators":{"disabled":true},"disableLocalVideoFlip":true,"disableSelfViewSettings":true,"doNotFlipLocalVideo":true,"hideConferenceSubject":true,"hideParticipantsStats":true,"hideConferenceTimer":true,"notifications":[],"prejoinPageEnabled":false,"remoteVideoMenu":{"disabled":true},"startWithAudioMuted":true,"startWithVideoMuted":true,"toolbarButtons":["camera","desktop","microphone","fullscreen","hangup","videoquality","select-background","tileview"],"useHostPageLocalStorage":true}

2022-09-21T06:19:09.295Z [features/base/config] Extending interfaceConfig with: {"SHOW_CHROME_EXTENSION_BANNER":false,"VIDEO_QUALITY_LABEL_DISABLED":true}

2022-09-21T06:19:09.376Z [FeatureFlags] <Object.init>:  Source name signaling: true, Send multiple video streams: true, SSRC rewriting supported: false, uses Unified plan: true

2022-09-21T06:19:09.387Z [modules/RTC/ScreenObtainer.js] <Object._createObtainStreamMethod>:  Screen sharing not supported on  chrome

2022-09-21T06:19:09.396Z [modules/RTC/ScreenObtainer.js] <Object.init>:  Desktop sharing disabled

2022-09-21T06:19:09.409Z [modules/connectivity/NetworkInfo.js] <Wn.updateNetworkInfo>:  updateNetworkInfo {isOnline: true}isOnline: true[[Prototype]]: Object

2022-09-21T06:19:09.461Z [features/base/media] Start muted: audio, video

2022-09-21T06:19:09.476Z [features/base/media] Start audio only set to false

[Amplitude] Cleaning up cookies availability test

[Amplitude] Cleaning up cookies availability test

2022-09-21T06:19:09.571Z [features/analytics] Initialized 1 analytics handlers

2022-09-21T06:19:09.677Z [index.web] <HTMLDocument.<anonymous>>:  (TIME) document ready:	 6596.60000000149

2022-09-21T06:19:09.769Z [modules/RTC/RTCUtils.js] <Lc>:  list of media devices has changed: [I am not putting details of devices here intnetionally]

2022-09-21T06:19:10.182Z [features/base/lastn] There is no active conference, not updating last N

There are no logs in the browser after this and I never receive ‘videoConferenceJoined’ event after this.

Can you share a code snippet of how you are using the iframe API?

@saghul

I have included “https://meet.jit.si/external_api.js” in my index.html page. Upon user action, I initialize iFrame with below given configuration.

var api = new window.JitsiMeetExternalAPI('meet.jit.si', {
            roomName: 'guid-goes-here',
            width: '100%',
            height: '100%',
            parentNode: document.querySelector(`#video-call-layout-iframe`),
            userInfo: {
              email: 'email-address-goes-here',
              displayName: 'full-name-goes-here'
            },
            configOverwrite: {
              prejoinPageEnabled: false,
              toolbarButtons: [
                'camera',
                'desktop',
                'microphone',
                'fullscreen',
                'hangup',
                'videoquality',
                'select-background',
                'tileview'
              ],
              notifications: [],
              hideConferenceSubject: true,
              hideConferenceTimer: true,
              hideParticipantsStats: true,
              startWithVideoMuted: !userMediaDevicesPreference.isCameraOn,
              startWithAudioMuted: !userMediaDevicesPreference.isMicrophoneOn,
              disableSelfViewSettings: true,
              connectionIndicators: {
                disabled: true
              },
              disableLocalVideoFlip: true,
              doNotFlipLocalVideo: true,
              buttonsWithNotifyClick: [
                'hangup'
              ],
              useHostPageLocalStorage: true,
              remoteVideoMenu: {
                disabled: true
              }
            },
            interfaceConfigOverwrite: {
              VIDEO_QUALITY_LABEL_DISABLED: true,
              SHOW_CHROME_EXTENSION_BANNER: false
            }
          });

api.addListener('videoConferenceJoined', () => {

 console.log('Video conference joined');

});

This is strange, I pasted your sample in jitsi-meet/api.html at master · jitsi/jitsi-meet · GitHub
Add <div id="video-call-layout-iframe"/> before the script tag and everything works here. I see the print ‘Video conference joined’
1663873071359.log (68.9 KB)

@damencho I was facing this problem on a mobile device with chrome browser.

Also, I ran this code through StackBlitz on my mobile chrome browser and it seems to be working fine there as well.

Do you think it has something to do with me using LetsEncrypt SSL certificate with my app? Or do you have any other suggestion?

Let’s Encrypt should just work. Try to use the remote inspector and check the network tab, are there any failing requests?