'Continue to App' button not working for IOS App

I have installed jitsi meet on my own server and re-branded Android and IOS apps with a little customization.
When on mobile, “Download App” button is redirecting to the app store perfectly on both Android and IOS.
BUT It’s redirecting to the App correctly on Android phone by clicking on ‘Continue to the app’ button but it’s not redirecting on Iphone/Ipad.

Here is how I setup ‘interface_config.js’ ( https://prnt.sc/r1xq43 ). I didn’t make any other change but just changed links, APP_SCHEME and ANDROID_APP_PACKAGE .

You need add your custom scheme (APP_SCHEME) to iOS for deep linking. Also, you’ll need to set it up here: https://github.com/jitsi/jitsi-meet/blob/3e40bb19cdb79d685fd81cf494f42a5c3f5916ba/ios/app/src/AppDelegate.m#L43

Thank you Saghul,

You mean (APP_SCHEME) in ‘interface_config.js’ file?, Yes, I did that. I also changed the link as you specified but it’s still doesn’t do anything on ‘Continue to the app’ button. It doesn’t even open any other link.

Did you edit yiour iOS app to register that scheme?

Yes, I did change as you specific in the previous reply (https://github.com/jitsi/jitsi-meet/blob/3e40bb19cdb79d685fd81cf494f42a5c3f5916ba/ios/app/src/AppDelegate.m#L43).

Now I noticed that ‘continue to the app’ button is working on ‘chrome’ but not on ‘Safari’ on IOS.

That’s weird. Did you configure the scheme in Xcode like so?

Yes, that’s correct. Is that possible if you can test the official jitsi app from the official link (https://meet.jit.si/) on Safari on your Iphone. It may roll out any issue on my side. Because I see some issues on ‘download to the app’ and ‘continue to the app’ on IOS on official jitsi app too.

It works fine here. I think I forgot to tell you one thing though. You will want to have this file in your webserver (matching your app ID): http://meet.jit.si/.well-known/apple-app-site-association

Can you please clarify a bit. only App’s ID needs to be changed or App_Scheme too?, also it should be changed from both places?. https://prnt.sc/rbjneb

Regarding Webserver, it’s the server on which jitsi is installed OR it’s the server from which I’m creating meeting rooms via API?, if it’s the server i’m creating rooms via API, then this file will be uploaded in root or in the directory (from which I’m creating room via API)

{“applinks”: {“apps”: , “details”: [{“paths”: [“NOT /static/", "”], “appID”: “1494133443.org.jitsi.meet”}, {“paths”: [“NOT /static/", "”], “appID”: “1494133443.com.atlassian.JitsiMeet.ios”}]}}

They are both app IDs, it just happens that one is the same as the schema, I can see how that is confussing, sorry.

It’s the domain on which jitsi runs.

Can you please check if this is correct
" {“applinks”: {“apps”: , “details”: [{“paths”: [“NOT /static/", "”], “appID”: “1494133443”}, {“paths”: [“NOT /static/", "”], “appID”: “1494133443”}]}} "

Also, I put the file in /usr/share/jitsi-meet , is this correct location ?

because it’s still not working.

NOTE: This issue is only when room is created with API, it works fine when room is created from the main page like (jitsi.domain.com) without API.

The app ID is wrong. It’s the team ID + the app bundle ID.

You mean on a page within an iframe? Then maybe you need to add the AASA file to that domain too!

I highly appreciate your assistance.

I have corrected App’s Bundle ID with TeamID and placed the file on both servers but still same thing. Just to confirm it’s correct location to place the file on jitsi server (/usr/share/jitsi-meet )
Here is how I implemented API.

        var domain = "jitsi.domain.com";
        var options = {
			roomName: "testroom",
        var api = new JitsiMeetExternalAPI(domain, options);

Also create a .well-known directory and put it there. Last, check you can access it with the browser.

At a first glance, that should work. Though I have never tried it myself, so I wonder if Safari itself is just not allowing it.

I have added the apple-app-site-association file under /usr/share/.well-known folder with correct IDs
but when i want to go to

I get


Problem accessing /.well-known/apple-app-site-association. Reason:

Not Found

Powered by Jetty:// 9.4.15.v20190215

If it is a Jetty problem, how can i configure Jetty ??

And strangely, my previous installations of jitsi-meet doesn’t have this file and works perfectly with safari for “continue to app” linking… what may have caused this?

You may want to reinstall. Install nginx beforehand and Jitsi will cconfigure itself to use it. We have deprecated the builtin Jetty server and it won’t be used anymore in future releases.

A fresh install from scratch with nginx but the result is same… i use stable build

I think the problem is due to Iframe. Is there any other solution in your mind?,

There is another issue in which most of times, jitsi is not removing the user (his thumbnail) even he has left the room. When a moderator has been left the room, it makes that user as moderator, and I can’t even ‘kick out’ the user .

How to use this End Meeting API, I tried but it’s giving an error ( api.dispose())

I wonder if anyone else has problems with Safari browser on mobile?? When i click for a meeting from my website, deeplink triggers this download app - continue to app screen but at this screen nothing happens in Safari browser, both buttons are deactive, but chrome browser works fine in mobile.

My previous jitsi installations works perfectly with the same setup; but when i started using the latest builds it stopped linking on safari…

I have added apple-app-site-association file in .well-known folder and as it is already known by nginx, it is opened like meet.jit.si; but i did not help… Strange thing is i never needed such a file before…

I am observing this problem when i call this link from my website, if i directly copy/paste the link https://meet1.mydomain.com/roomname?jwt=blabla to safari browser, continue to app works fine and opens my mobile app.

any suggestions will be much appreciated, as i am unable to give service from Safari on mobile right now…

I’m having a similar issue where I can get the iOS app to open upon clicking Continue to App but it doesn’t go to the room in the link…it just opens the app without starting the meeting in the room the “Continue to App” initiated from.