Connection timed out error after installing jisti

getting the below error trace from jicofo.log

SEVERE: [32] [xmpp_connection=client] XmppProviderImpl.doConnect#228: Failed to connect/login: The following addresses failed: ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/104.21.22.95:5222)’ failed because: java.net.SocketTimeoutException: Connect timed out, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/172.67.203.203:5222)’ failed because: java.net.SocketTimeoutException: Connect timed out, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/[2606:4700:3034:0:0:0:ac43:cbcb]:5222)’ failed because: java.net.SocketException: Network is unreachable, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/[2606:4700:3033:0:0:0:6815:165f]:5222)’ failed because: java.net.SocketException: Network is unreachable
org.jivesoftware.smack.SmackException$EndpointConnectionException: The following addresses failed: ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/104.21.22.95:5222)’ failed because: java.net.SocketTimeoutException: Connect timed out, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/172.67.203.203:5222)’ failed because: java.net.SocketTimeoutException: Connect timed out, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/[2606:4700:3034:0:0:0:ac43:cbcb]:5222)’ failed because: java.net.SocketException: Network is unreachable, ‘RFC 6120 A/AAAA Endpoint + [meet.gigsboard.com:5222] (meet.gigsboard.com/[2606:4700:3033:0:0:0:6815:165f]:5222)’ failed because: java.net.SocketException: Network is unreachable
at org.jivesoftware.smack.SmackException$EndpointConnectionException.from(SmackException.java:334)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectUsingConfiguration(XMPPTCPConnection.java:663)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.connectInternal(XMPPTCPConnection.java:846)
at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:529)
at org.jitsi.impl.protocol.xmpp.XmppProviderImpl.doConnect(XmppProviderImpl.java:208)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:167)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:539)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
at java.base/java.lang.Thread.run(Thread.java:833)

Can you share /etc/jitsi/jicofo/config?

sure. Below is the config file

Jitsi Conference Focus settings

sets the host name of the XMPP server

JICOFO_HOST=meet.mydomain.com

sets the XMPP domain (default: none)

JICOFO_HOSTNAME=meet.mydomain.com

sets the XMPP domain name to use for XMPP user logins

JICOFO_AUTH_DOMAIN=auth.meet.mydomain.com

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD=***********

extra options to pass to the jicofo daemon

JICOFO_OPTS=""

adds java system props that are passed to jicofo (default are for home and logging config file)

JAVA_SYS_PROPS="-Dconfig.file=/etc/jitsi/jicofo/jicofo.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

This should be

JICOFO_HOST=localhost

if prosody and jicofo are on the same host

1 Like

Okay. Let me try that

@emrah thank you that worked. But having another issue now. only one applicant is showing on the meet.

Do participants join the meeting using the same domain set during the installation?

Yes.

@emrah that one fixed. Now I’m facing another issue. All the participants are moderators.

Did you enable authentication for jicofo?

Secure Domain setup · Jitsi Meet Handbook one right? yes