Connection refused on port 5347

Hi there, I have had all the problems you can think of with this software and now I think it is going to work I get:
JVB 2020-03-14 16:33:21.623 SEVERE: [28] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Verbinding is geweigerd (Connection refused), host:jitsimeet.mydomain.dk, port:5347

With this line in my iptables:
#Jitsimeet
iptables -A INPUT -p udp -i enp3s0 --dport 10000:20000 -m state --state NEW -j ACCEPT
#JitsimeetXMMP
iptables -A INPUT -p udp -i enp3s0 --dport 5347 -m state --state NEW -j ACCEPT
iptables -A INPUT -p tcp -i enp3s0 --dport 5347 -m state --state NEW -j ACCEPT

And nothing else using this port.

What can be the problem here?

Oke, solved. Good to mention: Webmin use not only tcp 10000 but also udp :wink:

But still no working server, from jicofo.log
Error while discovering the services of jitsimeet.mydomain.dk

Help

And jicofo.log extra:
Jicofo 2020-03-14 17:34:20.723 SEVERE: [39] org.jitsi.meet.ComponentMain.log() host-unknown, host:localhost, port:5347
org.xmpp.component.ComponentException: host-unknown
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:243)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:286)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)

And jvb.log
JVB 2020-03-14 17:35:09.486 INFO: [18] org.jitsi.videobridge.health.Health.log() Performed a successful health check in 54ms. Sticky failure: false
JVB 2020-03-14 17:35:14.552 FINE: [312] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId 2osOk-402):
JVB 2020-03-14 17:35:19.486 INFO: [18] org.jitsi.videobridge.Videobridge.log() CAT=stat create_conf,conf_id=6f4165ea9dc1caa8 conf_name=null,logging=false,conf_count=1,ch_count=0,v_streams=0
JVB 2020-03-14 17:35:19.521 INFO: [18] org.jitsi.videobridge.health.Health.log() Performed a successful health check in 35ms. Sticky failure: false
JVB 2020-03-14 17:35:24.553 FINE: [335] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId 2osOk-404):
JVB 2020-03-14 17:35:29.522 INFO: [18] org.jitsi.videobridge.Videobridge.log() CAT=stat create_conf,conf_id=609a6b560f4d6c07 conf_name=null,logging=false,conf_count=1,ch_count=0,v_streams=0
JVB 2020-03-14 17:35:29.576 INFO: [18] org.jitsi.videobridge.health.Health.log() Performed a successful health check in 55ms. Sticky failure: false
JVB 2020-03-14 17:35:34.556 FINE: [358] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId 2osOk-406):

Can you paste your jicofo and prosody configs? Something seems to be misconfigured.

I am happy to:
jicofo config

Jitsi Conference Focus settings

sets the host name of the XMPP server

JICOFO_HOST=localhost

sets the XMPP domain (default: none)

JICOFO_HOSTNAME=

sets the secret used to authenticate as an XMPP component

JICOFO_SECRET=C#94K3SS

sets the port to use for the XMPP component connection

JICOFO_PORT=5347

sets the XMPP domain name to use for XMPP user logins

JICOFO_AUTH_DOMAIN=auth.mydomain

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD=26MMTKka

extra options to pass to the jicofo daemon

JICOFO_OPTS=""

adds java system props that are passed to jicofo (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

jvb config

Jitsi Videobridge settings

sets the XMPP domain (default: none)

JVB_HOSTNAME=mydomain

sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

JVB_HOST=

sets the port of the XMPP server (default: 5275)

JVB_PORT=5347

sets the shared secret used to authenticate to the XMPP server

JVB_SECRET=89#OJMTO

extra options to pass to the JVB daemon

JVB_OPTS=""

adds java system props that are passed to jvb (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

prosody config

– Plugins path gets uncommented during jitsi-meet-tokens package install - that’s where token plugin is located
–plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

VirtualHost “mydomain”
– enabled = false – Remove this line to enable this host
authentication = “anonymous”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/mydomain.key”;
certificate = “/etc/prosody/certs/mydomain.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

Component “conference.mydomain” “muc”
storage = “none”
–modules_enabled = { “token_verification” }
admins = { “focus@auth.mydomain” }

Component “jitsi-videobridge.mydomain”
component_secret = “89#OJMAO”

VirtualHost “auth.mydomain”
ssl = {
key = “/etc/prosody/certs/auth.mydomain.key”;
certificate = “/etc/prosody/certs/auth.mydomain.crt”;
}
authentication = “internal_plain”

Component “focus.mydomain”
component_secret = “C#98C3AS”

Sorry, i missed the last one.

I have changed the domainname from the real one to mydomain…

I hope it is something simple.

Thx in advance, NB

Someone? Pls, i have to give class tomorow and schools closed.

NB

Try changing JICOFO_HOSTNAME=mydomain and restart jvb then jicofo.

Oke, done that, it seems that it makes lesser mistakes now. But I am back at my initial problem “connection refused”
Last log message jicofo.log

Jicofo 2020-03-15 17:21:42.000 SEVERE: [36] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Verbinding is geweigerd (Connection refused), host:familieberg, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Verbinding is geweigerd (Connection refused)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:286)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.net.ConnectException: Verbinding is geweigerd (Connection refused)
at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)
at java.base/java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:399)
at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:242)
at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:224)
at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403)
at java.base/java.net.Socket.connect(Socket.java:609)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)
… 10 more
Jicofo 2020-03-15 17:21:44.336 SEVERE: [41] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 Failed to connect/login: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1059)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:834)
Jicofo 2020-03-15 17:21:44.340 WARNING: [128] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener() Connection XMPPTCPConnection[not-authenticated] (0) closed with error
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:834)

I have checked my firewall for several ports. 10000-20000 (webmin on other port udp and tcp)
Port 5347 accepted.
/var/log/jitsi# lsof -i:5347
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
lua5.1 15380 prosody 3u IPv4 507376 0t0 TCP localhost:5347 (LISTEN)
lua5.1 15380 prosody 4u IPv6 507377 0t0 TCP localhost:5347 (LISTEN)

So, i don’t know how to solve this now…

I saw that video and xmmp used the same port number. Is that normal? I give them two difference numbers now. 5275 and 5347.
Still constant reconnect with firefox, webcam and sound on.

I have in my firewall reject-with icmp-port-unreachable is this a problem?