Connection refused error

I have installed Jitsi in AWS ubuntu 16.4 server but I am getting this connection error as below:

URL - http://vc.imsprime.com/

Error in jocofo log

Jicofo 2020-04-19 01:04:09.876 SEVERE: [36] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused (Connection refused)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:285)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:607)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)

I tried the same with ssl:
https://vc.imsprime.com/

File permission:

/etc/jitsi/
drwxr-xr-x 6 root root 4096 Apr 19 02:36 ./
drwxr-xr-x 111 root root 4096 Apr 19 02:36 …/
drwx------ 2 jicofo jitsi 4096 Apr 19 02:43 jicofo/
drwxr-x— 2 root jitsi 4096 Apr 19 02:40 jigasi/
drwxr-xr-x 2 root root 4096 Apr 19 02:43 meet/
drwxr-x— 2 jvb jitsi 4096 Apr 19 02:39 videobridge/

/usr/share#

drwxr-xr-x 4 jicofo jitsi 4096 Apr 19 02:36 jicofo/
drwxr-xr-x 4 jigasi jitsi 4096 Apr 19 02:40 jigasi/
drwxr-xr-x 13 ubuntu ubuntu 4096 Apr 19 02:36 jitsi-meet/
drwxr-xr-x 2 root root 4096 Apr 19 02:36 jitsi-meet-prosody/
drwxr-xr-x 2 root root 4096 Apr 19 02:36 jitsi-meet-web-config/
drwxr-xr-x 3 jvb jitsi 4096 Apr 19 02:36 jitsi-videobridge/

Port used:

netstat -an | grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
tcp6 0 0 ::1:5347 :::* LISTEN

lsof -i:5347
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
lua5.1 1420 prosody 8u IPv4 16768 0t0 TCP ip6-localhost:5347 (LISTEN)
lua5.1 1420 prosody 9u IPv6 16769 0t0 TCP ip6-localhost:5347 (LISTEN)

jicofo config

Jitsi Conference Focus settings

sets the host name of the XMPP server

JICOFO_HOST=vc.imsprime.com

sets the XMPP domain (default: none)

JICOFO_HOSTNAME=vc.imsprime.com

sets the secret used to authenticate as an XMPP component

JICOFO_SECRET=CAJ7CKbE

sets the port to use for the XMPP component connection

JICOFO_PORT=5347

sets the XMPP domain name to use for XMPP user logins

JICOFO_AUTH_DOMAIN=auth.vc.imsprime.com

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD=KdQUB7uo

extra options to pass to the jicofo daemon

JICOFO_OPTS=""

adds java system props that are passed to jicofo (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

Can anyone please reply the solution it is bit urgent.

Thanks

Check that prosody config file is being read,

When I upgraded prosody I had to manually add,

Include "conf.d/*.cfg.lua"

to /etc/prosody/prosody.cfg.lua

So even when everything was ok, it was not reading my config file.

Hi,

I have installed the jitsi meet on my server successfully, and everything is working fine. Now I need to embed the server using external api option, provided by Jitsi team. But when I try to connect to the server from my application using the javascript API, it gives me “refused to connect” error, while I can access the server as well as port 5437, successfully from my remote machine. Therefore:

  1. If i try to access the jitsi meet server using the configured URL i.e. https://server.domain…com I can successfully do so

  2. If I check whether port 5437 is open for remote connections using telnet command from my machine to the server where jitsi is installed, the connection is successful

  3. But when I try to connect to the jitsi meet server, using the javascript API, the connection gets refused. Below the the simple code I have used to connect

function startMeeting(){
const domain = ‘server.domain.name.com’;
const options = {
roomName: ‘Sample’,
width: 500,
height: 300,
parentNode: document.querySelector(’#jitsi-meet’),
};

appObj = new JitsiMeetExternalAPI(domain,options);

}

I have tried almost all the solutions provided in this regard in the community forum but with no success.

Also please note that in my jicofo/config file the JICOFO_HOST value is set to localhost while JICOFO_HOSTNAME value is set to server domain name.
In videobridge/config file the value JVB_HOST is not set …

I have tried after setting all these values also to my host server, still no luck …

As I am relatively new to JITSI, request to help & guide in this regard.

Thanks !!

Maybe upload js console logs, so we can see the error?
The only used ports from outside are tcp 443 for the https and udp 10000 to send media to the bridge.

Hi, thanks for your prompt reply. On console I have the below error, please note I am using apache as web server on linux (UBUNTU) …

" Refused to display ‘https://server.name.com/Sample#jitsi_meet_external_api_id=0’ in a frame because it set ‘X-Frame-Options’ to ‘deny’ "

As far as I know, I can handle this by changing the header setting in .htaccess file … but is there any way I can verify by altering any setting in JITSI server, whether the page is displayed or not because the error displayed is “server refused to connect

PS: I have a laravel application running on port 443 on the same server, and I want to integrate the JITSI server in this application.
Both LARAVEL & JITSI are installed in the same server and are configured to be called using different domain names. Both are configured to be accessed using https and I can access both from my browser, without any issue. It is just when I try to use the external javascript API, I am facing this issue.

Thanks,

Hi … I resolved the issue by changing the header value of X-Frame-Options for apache … it now works fine and is successfully embedded.

Many thanks for your help !!