CONNECTION_FAILED event handling and connection quality status range

Yes, there’s http-bind ping every 10 seconds from client.

Hi @damencho I have reinstalled the Jitsi following quick install repo readme.md, kept everything default, and still users are dropping, on Jitsi UI, it throws to rejoin prompt, can you please help me out here?

Blockquote
VM408 backend.js:6 2020-01-24T09:44:27.414Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Ping timeout
at VM401 lib-jitsi-meet.min.js:22
at r.TimedHandler.handler (VM401 lib-jitsi-meet.min.js:6)
at r.TimedHandler.run (VM401 lib-jitsi-meet.min.js:6)
at r.Connection._onIdle (VM401 lib-jitsi-meet.min.js:6)
at r.Connection. (VM401 lib-jitsi-meet.min.js:6)
r @ VM408 backend.js:6
o @ VM401 lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ VM401 lib-jitsi-meet.min.js:22
window.onerror @ VM402 app.bundle.min.js:1
callErrorHandler @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:22
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
run @ VM401 lib-jitsi-meet.min.js:6
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
setTimeout (async)
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
VM408 backend.js:6 2020-01-24T09:44:27.418Z [modules/xmpp/strophe.ping.js] Ping timeout null
r @ VM408 backend.js:6
o @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:22
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
run @ VM401 lib-jitsi-meet.min.js:6
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:32.539Z [modules/xmpp/JingleSessionPC.js] <w.peerconnection.oniceconnectionstatechange>: (TIME) ICE disconnected P2P? false: 120320.81000006292
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:33.106Z [modules/xmpp/JingleSessionPC.js] <w.peerconnection.oniceconnectionstatechange>: (TIME) ICE connected P2P? false: 120888.11499997973
VM408 backend.js:6 2020-01-24T09:44:37.445Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Ping timeout
at VM401 lib-jitsi-meet.min.js:22
at r.TimedHandler.handler (VM401 lib-jitsi-meet.min.js:6)
at r.TimedHandler.run (VM401 lib-jitsi-meet.min.js:6)
at r.Connection._onIdle (VM401 lib-jitsi-meet.min.js:6)
at r.Connection. (VM401 lib-jitsi-meet.min.js:6)
r @ VM408 backend.js:6
o @ VM401 lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ VM401 lib-jitsi-meet.min.js:22
window.onerror @ VM402 app.bundle.min.js:1
callErrorHandler @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:22
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
run @ VM401 lib-jitsi-meet.min.js:6
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
setTimeout (async)

VM408 backend.js:6 2020-01-24T09:44:37.451Z [modules/xmpp/strophe.ping.js] Ping timeout null
r @ VM408 backend.js:6
o @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:22
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
run @ VM401 lib-jitsi-meet.min.js:6
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
setTimeout (async)

VM408 backend.js:6 2020-01-24T09:44:39.389Z [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: Request 47 timed out, over 66 seconds since last activity
r @ VM408 backend.js:6
o @ VM401 lib-jitsi-meet.min.js:6
i.Strophe.log @ VM401 lib-jitsi-meet.min.js:22
warn @ VM401 lib-jitsi-meet.min.js:6
_onIdle @ VM401 lib-jitsi-meet.min.js:6
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
setTimeout (async)
_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
setTimeout (async)

_onIdle @ VM401 lib-jitsi-meet.min.js:6
(anonymous) @ VM401 lib-jitsi-meet.min.js:6
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:40.478Z [modules/xmpp/xmpp.js] <t.value>: (TIME) Strophe connfail[item-not-found]: 128260.08999999613
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:40.484Z [modules/xmpp/xmpp.js] <t.value>: (TIME) Strophe disconnected[item-not-found]: 128266.01999998093
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:40.486Z [modules/xmpp/strophe.ping.js] <s.value>: Ping interval cleared
VM401 lib-jitsi-meet.min.js:6 2020-01-24T09:44:40.490Z [modules/statistics/statistics.js] <Function.S.sendAnalyticsAndLog>: {“type”:“operational”,“action”:“connection.failed”,“attributes”:{“error_type”:“connection.otherError”,“error_message”:“item-not-found”,“suspend_time”:9,“time_since_last_success”:68454}}

Is http-bind address working?
Share the prosody version you use and the prosody config you have.
Do you see any errors in prosody logs?

Got log while installing : jitsi-meet-prosody (1.0.3729-1)
Prosody config :
VirtualHost “subdomain.domain.com
– enabled = false – Remove this line to enable this host
authentication = “anonymous”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/subdomain.domain.com.key”;
certificate = “/etc/prosody/certs/subdomain.domain.com.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

Component “conference.subdomain.domain.com” “muc”
storage = “none”
–modules_enabled = { “token_verification” }
admins = { “focus@auth.subdomain.domain.com” }

Component “jitsi-videobridge.subdomain.domain.com
component_secret = “MQGafWL0”

VirtualHost “auth.subdomain.domain.com
ssl = {
key = “/etc/prosody/certs/auth.subdomain.domain.com.key”;
certificate = “/etc/prosody/certs/auth.subdomain.domain.com.crt”;
}
authentication = “internal_plain”

Component “focus.subdomain.domain.com
component_secret = “SnT@IHtp”

prosody logs :
Jan 24 11:33:22 bosh5b4f65ae-0143-4163-8bfc-01de667d428f info Authenticated as bc48c641-5880-4824-93bb-73875470e43e@subdomain.domain.com
Jan 24 11:33:32 mod_bosh info New BOSH session, assigned it sid ‘06361bc3-240f-42ec-b3e9-a0a7be500cc1’
Jan 24 11:33:33 bosh06361bc3-240f-42ec-b3e9-a0a7be500cc1 info Authenticated as 975ba9d2-4558-48f5-9e7a-db4ae1515002@subdomain.domain.com
Jan 24 11:33:44 mod_bosh info New BOSH session, assigned it sid ‘b03658c1-db01-4390-8a26-3872658beba9’
Jan 24 11:33:45 boshb03658c1-db01-4390-8a26-3872658beba9 info Authenticated as 936f1fb1-edfe-4e88-8c13-88eed236e91a@subdomain.domain.com
Jan 24 11:35:18 mod_bosh info New BOSH session, assigned it sid ‘2204b85a-44ad-473b-be5a-9069af3f21e5’
Jan 24 11:35:18 bosh2204b85a-44ad-473b-be5a-9069af3f21e5 info Authenticated as 904834c8-e2ba-41f4-bd26-e54178ae7fe8@subdomain.domain.com
Jan 24 11:35:44 mod_bosh info New BOSH session, assigned it sid ‘a41555e6-3a64-47e3-abc8-bc2f13fa3de3’
Jan 24 11:35:45 bosha41555e6-3a64-47e3-abc8-bc2f13fa3de3 info Authenticated as 690396ee-cc14-44dc-9d8b-80c899c76464@subdomain.domain.com
Jan 24 11:35:46 mod_bosh info New BOSH session, assigned it sid ‘dc1b9135-3a15-42c6-b851-959965654046’
Jan 24 11:35:46 boshdc1b9135-3a15-42c6-b851-959965654046 info Authenticated as df2db61d-fb33-4177-a9d7-64c39a07a2b1@subdomain.domain.com
Jan 24 11:37:19 mod_bosh info Client tried to use sid ‘2204b85a-44ad-473b-be5a-9069af3f21e5’ which we don’t know about
Jan 24 11:37:19 mod_bosh info Client tried to use sid ‘2204b85a-44ad-473b-be5a-9069af3f21e5’ which we don’t know about
Jan 24 11:37:23 mod_bosh info Client tried to use sid ‘a41555e6-3a64-47e3-abc8-bc2f13fa3de3’ which we don’t know about
Jan 24 11:37:23 mod_bosh info Client tried to use sid ‘a41555e6-3a64-47e3-abc8-bc2f13fa3de3’ which we don’t know about
Jan 24 11:38:01 mod_bosh info New BOSH session, assigned it sid ‘dfb0a564-fd68-47bd-bbbe-6b12fee99024’
Jan 24 11:38:02 boshdfb0a564-fd68-47bd-bbbe-6b12fee99024 info Authenticated as 18a39dee-d76a-46f5-ac2d-1d42a9db7379@subdomain.domain.com
Jan 24 11:38:08 mod_bosh info New BOSH session, assigned it sid ‘c5205e88-9be1-4378-8359-cf2f66cde774’
Jan 24 11:38:08 boshc5205e88-9be1-4378-8359-cf2f66cde774 info Authenticated as 0c151afc-891c-4e2f-aaf6-6c1a75225c6c@subdomain.domain.com
Jan 24 11:40:19 mod_bosh info Client tried to use sid ‘dfb0a564-fd68-47bd-bbbe-6b12fee99024’ which we don’t know about
Jan 24 11:40:19 mod_bosh info Client tried to use sid ‘dfb0a564-fd68-47bd-bbbe-6b12fee99024’ which we don’t know about

When user about to get Connection_failed error, http-bind calls seems to stop.

Normal as there are minute and the half between requests.

You have ping enabled, it is even in the client logs that ping timeouts … well seems either client loosing connection or server loosing connection and bosh requests timeout … look at the VM stats, network stats, usage and load … if running on some cloud provider, can it be to have stolen cpu time from a noisy neighbour …

Running on GCP n1-standard-4 (4 vCPUs, 15 GB memory)
Only Jitsi-server is running on this VM and nothing else (no other server)

Please find the CPU stats

Hi @damencho, I have been monitoring the meetings, I can see difference between meet.jit.si and our server is huge RTT(sometimes over 25k+) and when RTT spikes and stays same, CONNECTION_FAILED event occurs.
Even tried downgrading Jitsi to 1.0.3936-1, It seems less drops on this version but still no sure.

So that’s definitely the network in front of your server, in case that when you see big RTT between your client and your server and the RTT to meet.jit.si servers is low.

Hi @damencho I’ve got the proper browser logs for this error.
I can see CORS error for first http-bind request, and then user drops from call.
Sometime first http-bind call takes huge time to get response resulting user connection delay.

Btw I had already added following lines in prosody.cfg.lua way back, and this happens intermittently,
cross_domain_bosh = true;
consider_bosh_secure = true;

Is there any missing while doing CORS configuration for Jitsi-meet backend?

So the address you use to access your website and the bosh connection address configured in config.js are different, and you haven’t allow this situation in your nginx config. You can try adding:

location = /http-bind {
    ....
    add_header 'Access-Control-Allow-Origin' '*';
    ....
}

Thanks for the response @damencho .

Our Jitsi server installation is done using quick install readme.md documentation so I think default server is jetty (and not nginx).

Btw error mentioned comes intermittently in http-bind call. For all other http-bind, I can see Access-Control-Allow-Origin : “*” header present in http-bind calls.

Would you recommend us to shift to using NginX from Jetty? Will that resolve the issue since as soon as we see this error, we see a connection failed event and the user call drops. Thus it is critical for us to have a resolution of this issue and we are anxious to hear from you.

You will have more control and settings to handle those when using nginx.

Thanks again.

I have installed nginx and the Jitsi-meet, the issue I did face is add_header was adding duplicate header and hence http-bind call were throwing error “expected one value but got multiple”, so I changed it to proxy_set_header, now it works.

Edited because now everything works after doing fresh installation on fresh VM strange but after apt-get purge few config files were still there and causing problems.

Hi @Nilesh_Sargar @damencho
On mobile platform if internet is disconnected for 10 seconds or longer conference hangup. Can we increase this timeout around 30 seconds so that device gets enough buffer time to reconnect to internet. if so In what file do we need to make changes.

Regards

Good afternoon, I have the jitsi meet system on ubutu 18.04 tls 2 months ago, working correctly with several meetings with 27 clients, and two days ago he only let me create the room and if any participant enters it, it bounces this message “Unfortunately something went wrong. We are trying to fix this. Re-connecting in so many seconds¨ It does not allow more users to join the room, the truth is that I did not touch the configuration of the same and I do not explain how this problem can happen. After updating it to the latest version it keeps doing the same to me.

What are the js console logs saying?

I am seeing similar errors
The behavior is that E2E RTT latency spikes up to 46,384ms and then the call eventually disconnects, and says "The conference will be reloaded after xx seconds.'

Can you tell me if anything below looks out of the ordinary about my logs?

08-12 15:06:32.645 6445 6821 I ReactNativeJS: ‘[modules/xmpp/xmpp.js]’, '<>: ', ‘(TIME) Strophe connfail[item-not-found]:\t’, 1597259192645
08-12 15:06:32.647 6445 6821 I ReactNativeJS: ‘[modules/xmpp/xmpp.js]’, '<>: ', ‘(TIME) Strophe disconnected[item-not-found]:\t’, 1597259192646
08-12 15:06:32.647 6445 6821 I ReactNativeJS: ‘[modules/xmpp/strophe.ping.js]’, '<>: ', ‘Ping interval cleared’
08-12 15:06:32.647 6445 6821 I ReactNativeJS: ‘[modules/statistics/statistics.js]’, '<>: ', ‘{“type”:“operational”,“action”:“connection.failed”,“attributes”:{“error_type”:“connection.otherError”,“error_message”:“item-not-found”,“suspend_time”:7}}’

Further error messages:

Error Connecting through Bosh
org.jivesoftware.smack.SmackException: Timeout reached for the connection to null:0.

08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: Connection XMPPTCPConnection[not-authenticated] (9) closed with error
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: java.io.EOFException
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:169)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at java.io.InputStreamReader.read(InputStreamReader.java:233)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at java.io.BufferedReader.read(BufferedReader.java:325)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.kxml2.io.KXmlParser.fillBuffer(KXmlParser.java:1515)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.kxml2.io.KXmlParser.peekType(KXmlParser.java:992)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.kxml2.io.KXmlParser.next(KXmlParser.java:349)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.kxml2.io.KXmlParser.next(KXmlParser.java:313)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1352)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$1000(XMPPTCPConnection.java:1092)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1112)
08-12 14:54:59.562 7519 8111 W AbstractXMPPConnection: at java.lang.Thread.run(Thread.java:818)

08-12 14:55:03.613 7519 7546 W PingManager: XMPPConnection was not authenticated
08-12 14:55:03.619 7519 7546 W PingManager: XMPPConnection was not authenticated
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: shutdown
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: java.lang.NullPointerException: Attempt to invoke virtual method ‘org.igniterealtime.jbosh.AttrSessionID org.igniterealtime.jbosh.CMSessionParams.getSessionID()’ on a null object reference
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.applySessionData(BOSHClient.java:921)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.send(BOSHClient.java:498)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.disconnect(BOSHClient.java:586)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.disconnect(BOSHClient.java:567)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.jivesoftware.smack.bosh.XMPPBOSHConnection.shutdown(XMPPBOSHConnection.java:263)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.jivesoftware.smack.bosh.XMPPBOSHConnection.notifyConnectionError(XMPPBOSHConnection.java:419)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.jivesoftware.smack.bosh.XMPPBOSHConnection$BOSHConnectionListener.connectionEvent(XMPPBOSHConnection.java:466)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.fireConnectionClosedOnError(BOSHClient.java:1683)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.dispose(BOSHClient.java:705)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.processExchange(BOSHClient.java:1137)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.processMessages(BOSHClient.java:998)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient.access$300(BOSHClient.java:100)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at org.igniterealtime.jbosh.BOSHClient$RequestProcessor.run(BOSHClient.java:1727)
08-12 14:55:03.673 7519 8108 W XMPPBOSHConnection: at java.lang.Thread.run(Thread.java:818)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: Connection XMPPBOSHConnection[not-authenticated] (10) closed with error
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: org.igniterealtime.jbosh.BOSHException: Could not obtain response
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.ApacheHTTPResponse.awaitResponse(ApacheHTTPResponse.java:251)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.ApacheHTTPResponse.getBody(ApacheHTTPResponse.java:192)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.BOSHClient.processExchange(BOSHClient.java:1122)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.BOSHClient.processMessages(BOSHClient.java:998)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.BOSHClient.access$300(BOSHClient.java:100)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.BOSHClient$RequestProcessor.run(BOSHClient.java:1727)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at java.lang.Thread.run(Thread.java:818)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: Caused by: java.net.UnknownHostException: Unable to resolve host “jabber.airsuite-live.atheerair.com”: No address associated with hostname
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at java.net.InetAddress.lookupHostByName(InetAddress.java:470)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at java.net.InetAddress.getAllByNameImpl(InetAddress.java:252)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at java.net.InetAddress.getAllByName(InetAddress.java:215)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:142)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.java:169)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPooledConnAdapter.java:124)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:370)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:560)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:492)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at org.igniterealtime.jbosh.ApacheHTTPResponse.awaitResponse(ApacheHTTPResponse.java:235)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: … 6 more
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: Caused by: android.system.GaiException: android_getaddrinfo failed: EAI_NODATA (No address associated with hostname)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at libcore.io.Posix.android_getaddrinfo(Native Method)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at libcore.io.ForwardingOs.android_getaddrinfo(ForwardingOs.java:55)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: at java.net.InetAddress.lookupHostByName(InetAddress.java:451)
08-12 14:55:03.682 7519 8108 W AbstractXMPPConnection: … 15 more

Where do you see these messages?
It is something in the xmpp server, what do the prosody logs look like?

Hi Damencho, Sorry for bothering,
I think my problem was the java.net.UnknownHostException: Unable to resolve host.

The problem seems isolated to the specific device (Android 6.0.1) and and several google results have pointed to 6.0.1 as being the issue

The DNS sometimes does not resolve properly, but sometimes resolves fine.
There is a temporary fix of toggling the WiFi on the device, but the issue reoccurs after reboot.
Unfortunately, there are no newer ROMs after the 6.0.1 for this device :frowning: