Connecting Jigasi to Prosody


So I’m at the point where Jigasi tries to fetch a call via XMPP and translate it over to SIP for my PBX.

It appears to be having trouble with the SASL mechanism and registering with Prosody

2023-04-10 16:31:17.821 SEVERE: [117] Failed to connect to XMPP service for:ProtocolProviderServiceJabberImpl(
org.jivesoftware.smack.SmackException$SmackSaslException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: [PLAIN, SCRAM-SHA-1]. Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: [ANONYMOUS]. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS]. Skip reasons: []

The Jigasi config is OOB and it connects successfully to the brewery so I’m unsure where to look.

I do have this option set:

UPDATE: So I found the xmpp user auth section, and i was able to successfully register it seems, but now when i attempt to dial out, i get kicked out of the conference room. here are the logs:

2023-04-10 17:02:09.516 INFO: [63] Jingle : ON
2023-04-10 17:02:09.523 INFO: [63] JvbConference.registrationStateChanged#652: [ctx=16811461292384419057] Registering XMPP.
2023-04-10 17:02:09.685 INFO: [63]$JabberConnectionListener.authenticated: Authenticated: false
2023-04-10 17:02:09.734 INFO: [63] AudioModeration.xmppProviderRegistered#499: [ctx=16811461292384419057] Discovered for 56ms.
2023-04-10 17:02:09.735 INFO: [63] JvbConference.joinConferenceRoom#734: [ctx=16811461292384419057] Joining JVB conference room:
2023-04-10 17:02:09.912 INFO: [56]$MemberListener.joined: has joined the chat room.
2023-04-10 17:02:09.915 INFO: [54]$MemberListener.joined: has joined the chat room.
2023-04-10 17:02:09.918 INFO: [51]$MemberListener.joined: has joined the chat room.
2023-04-10 17:02:09.923 SEVERE: [63] JvbConference.registrationStateChanged#641: [ctx=16811461292384419057] Registered bosh sid: 70531cb0-97f2-4356-bacb-54403278df46
2023-04-10 17:02:10.206 INFO: [53]$MemberListener.left: has left the chat room.

any idea where to look? im just trying to get to the stage where my Opensips instance receives an INVITE from Jigasi.

Check prosody logs maybe there you can find the reason why the participant left the meeting.

From prosody.log on room login

Apr 10 17:41:30 mod_bosh	info	New BOSH session, assigned it sid '961070e5-9825-428c-ac7a-773bdc5af50f'
Apr 10 17:41:31 bosh961070e5-9825-428c-ac7a-773bdc5af50f	info	Authenticated as

On dialout attempt

^@^@Apr 10 17:43:33 mod_bosh	info	New BOSH session, assigned it sid 'cbae33ef-b7b7-4640-a62e-6b43bc632a11'
Apr 10 17:43:33 boshcbae33ef-b7b7-4640-a62e-6b43bc632a11	info	Authenticated as
Apr 10 17:43:34 bosh961070e5-9825-428c-ac7a-773bdc5af50f	info	BOSH client disconnected: session close

Does the authentication for xmpp on dialout need to be different than my room login?

What do you mean? Didn’t you create a dedicated user for jigasi?

Hi Damian,

I solved this on my own again. In the midst of troubleshooting, somehow my Jicofo bridge went down. I just rebooted jicofo and it works now. I get the SIP attempt.

Sorry. This is closed!