Connecting jigasi over ssh port forwarding

Hi,

I installed jigasi through apt on my local computer running Ubuntu and tried to connect it to my web server where there is a functioning jitsi installation present that I run through docker.

I expose prosody’s 5347 port to the docker host’s localhost and connect it to my computer with a port forwarding.

When I run the jigasi service, I get the following error:

    org.jitsi.meet.ComponentMain.log() host-unknown, host:localhost, port:5347
org.xmpp.component.ComponentException: host-unknown
	at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:243)
	at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
	at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
	at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:285)
	at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)

The reason for not using jigasi on the web server with the other components is that my phone provider only allows clients from inside my LAN to connect via SIP.

I started the docker container for jigasi once to copy the configuration to my local installation.

Any ideas? Do I need to forward more ports? Any special config values I need to set?

Setting JIGASI_OPTS="--nocomponent=true" did the trick.

I also had to forward prosody’s port 5222.

Now I’m stuck at:

impl.protocol.jabber.InfoRetreiver.retrieveDetails().369 Cannot load details for contact jigasi@auth.meet.jitsi : XMPPError: item-not-found - cancel

same here