Connecting from android app to own server with letsencrypt-cert and custom port fails

Hi,

Sorry I did find some similar topics about checking certificates, but couldn’t find something that helped me out.
Setup jitsi-meet with docker from here: https://github.com/jitsi/docker-jitsi-meet/blob/master/docker-compose.yml
I’m using a custom port for web http and https, everything else is default.
I’m using a certificate from let’s encrypt, chrome says “everything ok”

Cases:

  • Locally on my pc, I’m opening https://mydomain:myport/myroom and it works
  • On my mobile when I open the same link, I get a redirect saying I should use the app.
    – If I say I want a desktoppage within chrome (on my mobile) I’m connected without problems
    – If I click the redirect the jitsi-meet-app is opened

I’ m getting something like “The connection has been disconnected” (or similar, english is not my main language) from the beginning counting down from 30 to 0 and then closing this conenction window.

So as said on my mobile if I open the link in chrome everything works (besides the small, nearly unusable buttons), but the app refuses to work.
I tried logcat but it gives me a lot of output, don’t know where I may look at.

docker and android app are up to date, android is 8.0 on EMUI 8.0 (Honor 8)

Thanks for any help!

Found the problem and solution here:

It was a cert error, if you use letsencrypt and the jitsi-docker like me:

cp [letsencryptfolder]/[yourdomain].key [jitsifolder]/web/keys/cert.key
cp [letsencryptfolder]/fullchain.crt [jitsifolder]/web/keys/cert.crt

I made the mistake that I didn’t copy the fullchain.crt but [yourdomain].crt, so it worked on web, but not in the app.

To check if your cert is correct: https://whatsmychaincert.com/