Connect docker videobridge to external prosody

Hi, I have installed Jitsi meet Debian package to install jitsi-meet on ubuntu server and jitsi videobridge in docker container using following docker-compose file

services:
   # Video bridge
    jvb:
        build: ./jvb
        restart: ${RESTART_POLICY}
        ports:
            - '${JVB_MAPPED_PORT}:${JVB_PORT}/udp'
            - '${JVB_TCP_MAPPED_PORT}:${JVB_TCP_PORT}'
            - '${OCTO_MAPPED_PORT}:${OCTO_PORT}/udp'
        volumes:
            - ${CONFIG}/jvb:/config
        environment:
            - DOCKER_HOST_ADDRESS
            - XMPP_DOMAIN
            - XMPP_AUTH_DOMAIN
            - XMPP_INTERNAL_MUC_DOMAIN
            - XMPP_SERVER
            - JVB_AUTH_USER
            - JVB_AUTH_PASSWORD
            - JVB_BREWERY_MUC
            - JVB_PORT
            - JVB_TCP_HARVESTER_DISABLED
            - JVB_TCP_PORT
            - JVB_STUN_SERVERS
            - JVB_ENABLE_APIS
            - JVB_OCTO_BIND_PORT
            - JVB_OCTO_REGION
            - TZ
        networks:
            meet.jitsi:
                aliases:
                    - ${JVB_AUTH_USER}.${XMPP_DOMAIN}

# Custom network so all services can communicate using a FQDN
networks:
    meet.jitsi:

Now i want to connect videobridge inside docker to external xmpp (prosody) server

I am using following environment settings

#
# Basic configuration options
#

# Directory where all configuration will be stored
CONFIG=~/.docker-jvb-cfg

# System time zone
TZ=Asia/Kolkata

# Container restart policy
# Defaults to unless-stopped
RESTART_POLICY=unless-stopped

# Public URL for the web service (required)
PUBLIC_URL=https://my-domain

DOCKER_HOST_ADDRESS=My Public IP

# XMPP domain
XMPP_DOMAIN=my-domain

# XMPP server
XMPP_SERVER=xmpp.my-domain

# Internal XMPP server URL
XMPP_BOSH_URL_BASE=http://my-domain:5280

# Internal XMPP domain for authenticated services
XMPP_AUTH_DOMAIN=auth.my-domain

# XMPP domain for the MUC
XMPP_MUC_DOMAIN=muc.my-domain

# XMPP domain for the internal MUC used for jibri, jigasi and jvb pools
XMPP_INTERNAL_MUC_DOMAIN=internal-muc.my-domain

# MUC for the JVB pool
JVB_BREWERY_MUC=jvbbrewery

# XMPP user for JVB client connections
JVB_AUTH_USER=jvb

JVB_AUTH_PASSWORD=hello1

# STUN servers used to discover the server's public IP
JVB_STUN_SERVERS=meet-jit-si-turnrelay.jitsi.net:443

# Media port for the Jitsi Videobridge
JVB_PORT=10000
JVB_MAPPED_PORT=10881

# TCP Fallback for Jitsi Videobridge for when UDP isn't available
JVB_TCP_HARVESTER_DISABLED=false

JVB_TCP_PORT=443
JVB_TCP_MAPPED_PORT=8443

#OCTO Port
OCTO_PORT=4096
OCTO_MAPPED_PORT=8096

Can anyone tell me where is wrong in my configurations?