Configuring prejoinPageEnabled false doesn't seem to work

Hi All,

We have set up jitsi (docker-jitsi-meet-stable-7648-4) with docker on ECS. We have a web application which authenticates users and then they can create jitsi meeting. We are using jwt for authentication when the user tries to create the meeting. The prejoinPageEnabled value is set to false. But the page shows up with “Join Meeting” button and on clicking it nothing happens. The user is stuck on that screen.

This is under prosody env variables:

ENABLE_AUTH 1
ENABLE_GUESTS 0
JWT_APP_ID appId
JWT_APP_SECRET appSecret
JWT_AUTH_TYPE token
JWT_TOKEN_AUTH_MODULE token_verification

The js console log is as below:

Any idea what the problem is?

You need to use this:

config.prejoinConfig.enabled=false

Thank you. That solved my problem.

One more question, while I am here. Is there a plug-in to use that manages 1 moderator (who created the meeting) and all other users as guests? Or is this in built?

You can enable authentication on your deployment and moderators will need to login, the rest will join as guests.

Thanks