Configuring Etherpad with JitsiMeet installed using an IP address


#1

A big thanks for the Jisti Meet project and collaborators.

After a Quickinstall on Debian in Virtualbox:

(New users are linited to 2 urls. Below, @ means http:// and S@ means https:// Also space added before /)

  • Etherpad is running fine on @192.168.1.102 : 9001 /
  • Jitsimeet is running fine on S@192.168.1.102 /

But no share document option is available in Jitsimeet

I followed S@github.com /jitsi/jitsi-meet/wiki/Etherpad-addition-example
However nginx balked with this error:

nginx: [emerg] “location” directive is not allowed here in /etc/nginx/sites-enabled/chat.exemple.net

So I added a a server wrapping to the github example:

/etc/nginx/sites-available/chat.exemple.net

server{

Etherpad-lite

    location /etherpad/ {
    proxy_pass @192.168.1.102 : 9001 /;
    proxy_set_header X-Forwarded-For $remote_addr;
    proxy_buffering off;
    proxy_set_header       Host $host;
}

}

And also a link

ln -s /etc/nginx/sites-available/chat.exemple.net /etc/nginx/sites-enabled/chat.exemple.net

The JS is:

#cat /etc/jitsi/meet/chat.exemple.net-config.js
etherpad_base: ‘S @ 192.168.1.102 /etherpad/p/’,

Incidentally, thus url:
S@ 192.168.1.102 / etherpad
displays jitsimeet.

Best