Configure Appearance of Closed Captions/Subtitles

Hello, I was wondering how I could configure the appearance of the closed captioning?

Currently it looks like this for me:

You can see that the subtitles are stacked on top of one as the text-to-speech program processes the audio.

However, I would like the closed captioning to appear more like Google Meet, in that the subtitles stay in one line and get overwritten in place.
For example, this video about Jitsi closed captioning demonstrates the behaviour I am looking for.

I am currently using Vosk to handle the text-to-speech. It looks to me like the subtitles are showing multiple lines of partial text at once, however, I’m not sure where I can configure the UI to display one line of partial text at a time, or even just the full text for a sentence. I tried looking in the config.js and it said that subtitles could be configured in the interface_config file, but I believe that has been deprecated.

Any help, advice, or links would be appreciated. Thanks.

I think there is something wrong with the vosk implementation - like some transcriptions are not coming as a correction of the previous results, but like new transcriptions. Corrections should replace the previous one if visible and not duplicate them …

It is the same issue as is discussed in Jigasi Transcription with Vosk - repeated lines - #4 by damencho. Not yet solved, we need to properly handle partial results. Vosk returns partial from the start of the silence:

hello
hello world
hello world hello
hello world hello again

it seems like Jitsi expects only changed word in partial results, not very standard for Google too:

hello
world
hello
again
....

i had the issue in configuration can you guide me for the configuration
I don’t know what to do in below step

Hi I have some instructions I wrote for setting up jigasi with transcription, but at the moment they are not formatted well. I am in the process of making my docs publicly accessible.

You can find my in-progress work here: Configure Transcriber Authentication | Step by Step Dev (alexk2037.github.io)

Sorry for not writing all the details here in the forum, but hopefully this helps.

Also, anyone may use the content from the site and incorporate it into their own documentation.

I had tried above one on my system
after running the shell script i entered 4 (which is install option) but nothing is happening

whenever i am starting meet and enable caption button the transcriber join my meet automatically but doesn’t show any caption

i had enable the following thing
transcribingEnabled, DISABLE_TRANSCRIPTION_SUBTITLES
but still not working