Configuration and mobile app

To embed jitsi meet in my web page I use this configuration:

api = new JitsiMeetExternalAPI('meet.jit.si', {
	roomName: roomname,
	width: '100%',
	height: 700,
	parentNode: document.querySelector('#meetWrapper'),
	userInfo: {
		displayName: nickname,
		email: useremail
	},
	configOverwrite: {
		defaultLanguage: 'it',
		startWithVideoMuted: true
	},
	interfaceConfigOverwrite: {
		DEFAULT_REMOTE_DISPLAY_NAME: 'Partecipante',
		TOOLBAR_BUTTONS: ['microphone', 'camera', 'closedcaptions', 'desktop', 'fullscreen', 'fodeviceselection', 'hangup', 'profile', 'chat', 'etherpad', 'settings', 'raisehand', 'videoquality', 'filmstrip', 'shortcuts', 'tileview','download', 'help' $owner_buttons],
		SETTINGS_SECTIONS: setting_sections,
		TOOLBAR_ALWAYS_VISIBLE: true
	}
});

api.executeCommand('subject', title);
api.executeCommand('displayName', nickname);
api.addEventListener('readyToClose', function() {setTimeout(meetClose, 5000)});
window.jitsi = 1;

Since the web page is restricited to logged users I can activate different buttons and settings for the different users with variables $owner_buttons and setting_sections: ie only one user can make a livestream set a password, be a moderator or change the profile. On desktop browsers this setting works fine, however on android accessing the room with the app (following the link go to the app) these settings are not maintained eventhough I see them in the link url. For instance, with the android app any user can set a password or make a livestream.

Also accessing from the app the displayName is not set and user is shown as “Partecipante” (DEFAULT_REMOTE_DISPLAY_NAME)

In addition the setting TOOLBAR_ALWAYS_VISIBLE doesn’t seem to work on desktop browser.

interfaceConfig (and its overwrite) are not yet supported on mobile.

You mean on web or mobile? On mobile you need to set it in the userInfo object.

That sounds like a bug.

As you can see from my configuration the userInfo object is set. I also see in in the url towards the App but when the user is connected the name is “Partecipante”. I also tried to clear the App cache but the result didn’t change.

Please clarify what your scenario is. When on mobile what are you using, a browser, the SDK, the Jitsi Meet app?

I access the web page with the above configuration with Chrome for Android. Jitsi Meet tells that to partecipate I have to download and use the App. It shows the link to open the Jitsi Meet App and in the url I see my configuration (below). However when the App start the connection the displayName is generic: “Partecipant”.

intent://meet.jit.si/Riunione_xxyy#jitsi_meet_external_api_id=0&config.defaultLanguage=%22it%22&config.startWithVideoMuted=true&config.startAudioMuted=100&interfaceConfig.DEFAULT_REMOTE_DISPLAY_NAME=%22Partecipante%22&interfaceConfig.TOOLBAR_BUTTONS=%5B%22microphone%22%2C%22camera%22%2C%22closedcaptions%22%2C%22desktop%22%2C%22fullscreen%22%2C%22fodeviceselection%22%2C%22hangup%22%2C%22profile%22%2C%22chat%22%2C%22etherpad%22%2C%22settings%22%2C%22raisehand%22%2C%22videoquality%22%2C%22filmstrip%22%2C%22shortcuts%22%2C%22tileview%22%2C%22download%22%2C%22help%22%5D&interfaceConfig.SETTINGS_SECTIONS=%5B%22devices%22%2C%22language%22%5D&interfaceConfig.TOOLBAR_ALWAYS_VISIBLE=true&userInfo.displayName=%22Marco%20Rivo%22&userInfo.email=%22marco.rixy123%40gmail.com%22#Intent;scheme=org.jitsi.meet;package=org.jitsi.meet;end7

Got it.

I don’t think we currently support setting the display name from the URL on mobile.