Configurat for jibri

hi all,
When we start recording meeting,wo get some error.

If we set strip-from-room-domain=“b.” in jibri conf file. We got the error
https://test.doamin/111#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true
&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false&config.prejoinPageEnabled=false&config.requireDisplayName=false2021-02-19 10:22:47.212 FINE: [52] org.jitsi.jibri.selenium.pageobjects.CallPage.apply() Not joined yet: Cannot read property ‘isJoined’ of undefined

if we set strip-from-room-domain=“muc.” in jibri conf file. We got the error
https://test.doamin/b/111#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true
&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false&config.prejoinPageEnabled=false&config.requireDisplayName=false2021-02-19 10:22:47.212 FINE: [52]
org.jitsi.jibri.selenium.pageobjects.CallPage.apply() Not joined yet: APP is not defined

So what’s the meaning of the strip-from-room-domain? How can i configure it?

Try ‘conference.’ for that value. Note it ends with a .

Also the same error.

What is the correct url format?

jibri.conf.txt (4.5 KB)

This is a working jibri.conf(remove .txt extension).

Replace:
meet.example.com with your FQDN
JIBRI_PASSWORD and RECORDER_PASSWORD with actual passwords, after registering users jibri & recorder in proper domains.

Also change this to proper directory:
recordings-directory = “/etc/jitsi/recordings”


I can record now, but the recorded video is not a real video. The browser shows 404 in the video

The real address opened by the browser:
https://voiptest.com/b/111#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true

When I copy the address and visit it in the browser, a 404 phenomenon occurs

Hope 111 is the room name. Wonder what that extra character ‘b’ is though.
For me it looks like: https://meet.example.com/meetpr#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true

Seems you have that ‘b’ lurking somewhere.

If ‘b/111’(a little different meeting name) was the room name, it should have worked though. Works for me.

I have solved the redundant b, and now it appears that joining the meeting has failed until the threshold timeout

I checked the source code and found that the code has been trying to execute failed, I don’t know why

At present, I compile and install all the components of jitsi manually. Whether it conflicts with the version of jitsi-meet and jicofo I am using causes unsuccessful.
jitsi-meet, jicofo, jvb all use tag 5390
jibri uses the latest master, and I also tried tag v8.0, but they all failed when joined

Give it a try with this script. Jitsi Install Script For Ubuntu/Debian (also Jigasi and Jibri)