config.startScreenSharing=true for link

Hi all,

I would like to send a link to someone so it starts automatically with screen sharing instead of streaming their webcam. So the person only needs to give permission for screen sharing.

I thought the following would do the trick:

However, this does not seem to work. Can someone help me?

Kind regards,

Try removing start with video muted option.

Appears to work if I explicitly set config.startWithVideoMuted=false, but not if set to true or if option omitted.

Can optionally also add config.prejoinPageEnabled=false if you want user to go straight into meeting.



I was trying it on Firefox but it appears that does not work. Chrome and Edge do work however.

I can confirm that’s the case – startScreenSharing=true does not currently work with Firefox.

Problem is down to Firefox insisting that Screen Sharing can only be triggered by user action and not via script. Related issue: Screen sharing fail on Firefox with config startScreenSharing = true · Issue #5119 · jitsi/jitsi-meet · GitHub

Not sure if there is currently a way around that limitation.