Conference with > 2 users, but NOT with only two users

I followed the instructions for the manual installation with some small modifications that I pieced together from different posts. Now everything is working as soon as > 2 users are in the room. When there are exactly two users, they can see the other is present, but do NOT receive the audio or video from the other participant. When the room has 3 participants, everything immediately begins working, and when one leaves, it immediately stops working again.

The JVB logs have warnings like this

JVB 2021-09-06 22:56:12.046 WARNING: [96] [confId=d53606d5139bb5f3 gid=10782 type=video conf_name=wow@conference.MYDOMAIN] ChannelShim.lambda$setSourceGroups$2#289: Ignoring source group with <2 sources:
JVB 2021-09-06 22:56:12.046 WARNING: [96] MediaSourceFactory.getSourceSsrcs#399: Unprocessed source groups: Optional[]
JVB 2021-09-06 22:56:13.220 WARNING: [105] [confId=d53606d5139bb5f3 gid=10782 stats_id=Helga-JXp componentId=1 conf_name=wow@conference.MYDOMAIN ufrag=5icjj1feul70nv name=stream-b6cb0ad3 epId=b6cb0ad3 local_ufrag=5icjj1feul70nv] MergingDatagramSocket.initializeActive#599: Active socket already initialized.

And SEVERE errors like this:

JVB 2021-09-06 22:56:32.535 SEVERE: [116] [confId=d53606d5139bb5f3 epId=b6cb0ad3 gid=10782 stats_id=Helga-JXp conf_name=wow@conference.MYDOMAIN] DataChannelStack.onIncomingDataChannelPacket#81: Could not find data channel for sid 0

I have only seen other posts where things work with 2 users, but not more. Any ideas what could be causing this & how to fix it?

from what you say, you have accomplished the astonishing feat of not working in the P2P case and the fallback to JVB don’t work. Try to disable P2P in config.js it should (normally) work again. On how to make work P2P it’s probably safe to think that it comes from the ‘small’ changes you did.

I tried it last night with both p2p enabled as well as disabled. I’m not sure what the issue is exactly, but I made one config change and noticed that it worked in incognito mode. I’ll just describe it here in case anybody else stumbles upon this issue too.

I noticed that I was defining stunServers in the p2p object in the jitsi-meet’s config.js. I commented that out. So my p2p object in the config.js looked only like this:

p2p: { enabled: false }

I was connected with one normal Chrome tab from MacOS, and one iOS Safari tab. Neither user could see or hear each other. When I opened an incognito mode on the laptop, they could. I realized that the problem was the normal Chrome tab - maybe it had something cached. So one incognito tab and one iOS tab were able to communicate to each other correctly.