Conference lost after 20 seconds


#1

Greetings to the community,

I have a problem with Jitsi, I made the automatic installation on an Ubuntu 16 server, this process showed no error, however, when starting any conference, it is disconnected at 20 seconds, I share the following video where You can see the moment.

CLIK -> VIDEO

I have used my own ssl certificate generated by Godaddy, however, I do not understand if for the subdomain auth.domain it is necessary to buy or acquire another different certificate, I share the configuration of my jitsi, to see if any of you can help me solve my problem, thank you very much

/etc/prosody/conf.d/iclassflix.net.cfg.lua


#2

ICE failed normally is because of firewall, not doing port forwarding or not setting up jvb its local and public address, take a look at: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration


#3

damencho

Thank you very much for your quick response, the sending of a new video, where I compare you with my configuration and the firewall rules, however, the error continues, could you please tell me what other change you could make.

Click VIDEO 2

Thanks


#4

Your settings seem wrong to me, 10.x.x should be local address and in the public one is the public internet address where people over internet can access your server.


#5

@damencho Thank you very much for your indication, in fact the conference server, is already working correctly, my error was the IP.

I have another difficulty at this time, I am installing the recording system on a different machine, using the video (https://www.youtube.com/watch?v=OHHoqKCjJ0E) however, I do not execute the command

modprobe snd-aloop

It shows me the following error:

I have not found a way to install or execute it, could you tell me how to do it?

Thank you


#6

You need a linux kernel which has support for this device. Check your kernel.


#7

@damencho
Thanks for responding, I have a problem with the kernel change, I currently have my servers in Google Cloud, however, no matter how hard I try to make the change, this is not allowed, for security issues of Google, there is some way to correct jibri in kernel 4.15.0-1024-gcp?

Image 1

Image 2

Image 3


#8

You can use that kernel, you just need to compile the snd-aloop module.


#9

you could please tell me how I install it in ubuntu 16 tls I can not find it anywhere, please.


#10

@damencho Sorry for the inconvenience, but could not find anywhere, how to compile the module snd-aloop in the kernel 4.15.0-1024-gcp, could you please tell me how to do it. thank you