Colibri Websockets doesn't work with Docker installation (neither with reverse proxy nor without)

It looks like all requests are handled by the jitsi-meet web application. But the colibri-ws requests should be proxied to JVB. All components are running on the same server. So no Swarm, just docker-compose on a single server. Do I have to build my own meet image to proxy the colibri-ws requests to JVB to prevent all those errors?

My errors are the following with a custom UI (vuejs) with lib-jitsi-meet:


web_1 | 2021/01/26 22:34:40 [error] 257#257: *11 open() “/usr/share/jitsi-meet/colibri-ws/jvb_muc/d0…4c/25…49” failed (2: No such file or directory), client:, server: _, request:

prosody_1 | warn Component not connected, bouncing error for: <iq id=‘p2t7m-44’ from=‘…880’ to=‘’ type=‘get’>


2021-01-26T21:32:39.628Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: WebSocket stream error: host-unknown - This server does not serve

My connection options:

export default {
  hosts: {
    domain: '',
    muc: '' // FIXME: use XEP-0030
  // serviceUrl: 'wss://',
  bosh: '//', // FIXME: use xep-0156 for that

  // The name of client node advertised in XEP-0115 'c' stanza
  clientNode: ''

And if I opt out of websockets with plain BOSH over HTTP(s) I receive a bunch of CORS errors even if set in traefik config to allow all requests.

Was a configuration issue. The config.js gets overriden everytime I restart the containers and therefore I had to provide a custom-config.js file to solve those kind of issues. Also a few .env adjustments based on my setup were required.