/colibri/stats doesn't work!

Hello, I am trying to enable REST, particularly /colibri/stats. I’m doing a setup like number 3 in this guide - https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest.md. But in the end REST doesn’t work anyway, what am I doing wrong?

I’m trying to access the URL - https://meet.sustems.eu:4443/colibri/stats.

$ sudo cat /etc/jitsi/videobridge/sip-communicator.properties
[sudo] password for sustems:
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.meet.sustems.eu/.*
org.jitsi.videobridge.rest.jetty.host=::
org.jitsi.videobridge.rest.jetty.port=443
org.jitsi.videobridge.rest.jetty.ProxyServlet.hostHeader=meet.sustems.eu
org.jitsi.videobridge.rest.jetty.ProxyServlet.pathSpec=/http-bind
org.jitsi.videobridge.rest.jetty.ProxyServlet.proxyTo=http://localhost:5280/http-bind
org.jitsi.videobridge.rest.jetty.ResourceHandler.resourceBase=/usr/share/jitsi-meet
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./config.js=/etc/jitsi/meet/meet.sustems.eu-config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./interface_config.js=/usr/share/jitsi-meet/interface_config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./logging_config.js=/usr/share/jitsi-meet/logging_config.js
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./external_api.js=/usr/share/jitsi-meet/libs/external_api.min.js
org.jitsi.videobridge.rest.jetty.RewriteHandler.regex=^/([a-zA-Z0-9]+)$
org.jitsi.videobridge.rest.jetty.RewriteHandler.replacement=/
org.jitsi.videobridge.rest.jetty.SSIResourceHandler.paths=/
org.jitsi.videobridge.rest.jetty.tls.port=443
org.jitsi.videobridge.TCP_HARVESTER_PORT=443
org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePath=/etc/jitsi/videobridge/meet.sustems.eu.jks
org.jitsi.videobridge.rest.jetty.sslContextFactory.keyStorePassword=changeit

org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.ENABLE_STATISTICS=true

org.jitsi.videobridge.rest.private.jetty.sslContextFactory.keyStorePath=/etc/jitsi/videobridge/meet.sustems.eu.jks
org.jitsi.videobridge.rest.private.jetty.sslContextFactory.keyStorePassword=changeme
org.jitsi.videobridge.rest.private.jetty.tls.port=4443



$ sudo cat /etc/jitsi/videobridge/config
# Jitsi Videobridge settings

# sets the XMPP domain (default: none)
JVB_HOSTNAME=meet.sustems.eu

# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
JVB_HOST=

# sets the port of the XMPP server (default: 5275)
JVB_PORT=5347

# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=T7UlhCVk

# extra options to pass to the JVB daemon
JVB_OPTS=--apis=rest,xmpp


# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"
AUTHBIND=yes

Hi,

You should try “curl localhost:8080/colibri/stats” in the server. You may have to forward port 8080 in the nginx.

Regards,
Anthony

I deleted these lines to return the defaults and it worked!

org.jitsi.videobridge.rest.private.jetty.sslContextFactory.keyStorePath=/etc/jitsi/videobridge/meet.sustems.eu.jks
org.jitsi.videobridge.rest.private.jetty.sslContextFactory.keyStorePassword=changeme
org.jitsi.videobridge.rest.private.jetty.tls.port=4443

The truth is, I haven’t figured out why my private interface worked yet, I was doing as in Example 2 of this manual - https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest.md