Colibri Stats does NOT Work

Hi guys,

im struggling to get the colibri stats working on my second jitsi server, i followed this guide here How-to to setup Grafana dashboards to monitor Jitsi, my comprehensive tutorial for the beginner (STEP 4)

For the first server it worked without any problems. On the second server i get this if i try
“curl -v http://127.0.0.1:8080/colibri/stats

  • Trying 127.0.0.1…
  • TCP_NODELAY set
  • Connected to 127.0.0.1 (127.0.0.1) port 8080 (#0)

GET /colibri/stats HTTP/1.1
Host: 127.0.0.1:8080
User-Agent: curl/7.58.0
Accept: /

< HTTP/1.1 500 Request failed.
< Date: Mon, 10 Aug 2020 07:29:29 GMT
< Cache-Control: must-revalidate,no-cache,no-store
< Content-Type: text/html;charset=iso-8859-1
< Content-Length: 342
< Server: Jetty(9.4.15.v20190215)
<

Error 500 Request failed.

HTTP ERROR 500

Problem accessing /colibri/stats. Reason:

    Request failed.

Powered by Jetty:// 9.4.1 5.v20190215
* Connection #0 to host 127.0.0.1 left intact

I have checked the versions of both jitsi server and they are the same. Everything is nearly the same.

Server 1: (Jitsi stats WORKING)
ii jitsi-meet 2.0.4857-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4289-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4289-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4289-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4289-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-273-g072dd44b-1 all WebRTC compatible Selective Forwarding Unit (SFU)

Server 2: (jitsi stats are NOT working)

ii jitsi-meet 2.0.4857-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4289-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4289-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4289-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4289-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-273-g072dd44b-1 all

Here is the config from the sip.communities.properties for the NOT working jitsi server

rg.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meeting.mydomain.de
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=XXXXXXXXX
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meeting.mydomain.de
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=0efe76f9-e684-4e13-8edb-feed253a43db
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS= XXXXXXXXX
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS= XXXXXXXX
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc,colibri

Here are the config

Has anybody an idea ?
Help really apprecicated THANKS

Kindly Regards

Fabian

read the doc before setting configuration values can be a good idea.

org.jitsi.videobridge.STATISTICS_TRANSPORT - string property. A comma-separated list of transports. The supported transports are “muc” and “callstats.io”.

Hi gpatel-fr

thanks for the answer, i have already red the documentation. But on the second server is the configuration the same and there it works, i will give it try and update this post if its works.

Thanks

Fabian

Hi,

so i tried it, it does not help same behaviour as before, here is the updated config:

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.ji$
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meeting.mydomain.de
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=0WO@G7Jt
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meeting$
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=0efe76f9-e684-4e13-8edb-feed$
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS= xxxxxxxxxxx
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS= xxxxxxxxx
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
#org.jitsi.videobridge.STATISTICS_TRANSPORT=muc,colibri

I have restarted the whole server and services, same error.

Thanks in Advances.

Fabian

I can’t get further with you sorry :wink:

you have no idea what i could do?

Can anyone help please? Just an idea or hint is helpful enough…

Thanks!

Fabian