Colibri 404 error


On a new instance of Ubuntu 22.04, I followed the self-hosting instructions here:

Then I followed the Grafana instructions here:

When I did this on a previous instance, curl -v worked as expected. However the current instance returns:

*   Trying
* Connected to ( port 8080 (#0)
> GET /colibri/stats HTTP/1.1
> Host:
> User-Agent: curl/7.81.0
> Accept: */*
* Mark bundle as not supporting multiuse
< HTTP/1.1 404 Not Found
< Cache-Control: must-revalidate,no-cache,no-store
< Content-Type: text/html;charset=iso-8859-1
< Content-Length: 501
< Server: Jetty(11.0.10)
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>
<title>Error 404 Not Found</title>
<body><h2>HTTP ERROR 404 Not Found</h2>
<tr><th>MESSAGE:</th><td>Not Found</td></tr>
<hr/><a href="">Powered by Jetty:// 11.0.10</a><hr/>

* Connection #0 to host left intact

Any pointers on how to fix this would be appreciated.

My /etc/jitsi/videobridge/jvb.conf

videobridge {
    http-servers {
        public {
            port = 9090
    websockets {
        enabled = true
        domain = "jitsi.mydomain.corp:443"
        tls = true
    apis: {
      rest: {
        enabled: true
    ice: {
      udp: {
        port: 10000

Thanks, the apis block got curl to work. (What is the ice block for?)

Follow-up question: On another machine, X.X.X.X:3000 successfully opens Grafana, and I was able to add an InfluxDB data source with HTTP URL http://localhost:8086 and database jitsi. Saving & testing returns “datasource is working. 0 measurements found”. Why are there no measurements?

When I open an Influx terminal, show databases includes jitsi. After use jitsi, show measurements returns nothing. I thought Telegraf would create a measurement.

I use it to customize UDP port which is UDP/10000 by default. Not related with API…

I figured. Also, I was able to get Grafana working: In /etc/telegraf/telegraf.d/jitsi.conf, the input URL must be localhost and not the public IP address. Then Telegraf does create measurement jitsi_stats.