Cluster Screen Sharing Issue

Hi everyone,

I am using jitsi clusters. There are two servers (Videobridge and Nginx) for now. As for my problem, when I try to screen share in Jitsi, users see a gray screen. How can I fix this problem. I am attaching the logs below.

JVB 2022-02-07 13:54:12.167 INFO: [23] VideobridgeExpireThread.expire#140: Running expire()
JVB 2022-02-07 13:54:12.191 INFO: [24] HealthChecker.run#171: Performed a successful health check in PT0.00000168S. Sticky failure: false
JVB 2022-02-07 13:54:22.192 INFO: [24] HealthChecker.run#171: Performed a successful health check in PT0.000001107S. Sticky failure: false
JVB 2022-02-07 13:54:32.191 INFO: [24] HealthChecker.run#171: Performed a successful health check in PT0.00000103S. Sticky failure: false
JVB 2022-02-07 13:54:42.192 INFO: [24] HealthChecker.run#171: Performed a successful health check in PT0.000001158S. Sticky failure: false
JVB 2022-02-07 13:54:49.706 WARNING: [759] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28028, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:49.710 WARNING: [756] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28029, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:49.721 WARNING: [756] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28030, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:49.725 WARNING: [759] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28031, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:49.736 WARNING: [756] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28032, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:49.742 WARNING: [759] [confId=a62cd78064d0eda2 epId=bff8c4d9 gid=64837 stats_id=Magdalen-nJK conf_name=test@conference.meet.example.com] VideoQualityLayerLookup.transform#44: Unable to find encoding matching packet! packet=RtpPacket: PT=100, Ssrc=1061920364, SeqNum=28033, M=false, X=true, Ts=2959761146, TID=-1; sources=
JVB 2022-02-07 13:54:52.191 INFO: [24] HealthChecker.run#171: Performed a successful health check in PT0.000001115S. Sticky failure: false
JVB 2022-02-07 13:54:56.265 WARNING: [758] [confId=a62cd78064d0eda2 gid=64837 type=video conf_name=test@conference.meet.example.com] ChannelShim.lambda$setSourceGroups$2#289: Ignoring source group with <2 sources: <ssrc-group xmlns='urn:xmpp:jingle:apps:rtp:ssma:0' semantics='SIM'/>
JVB 2022-02-07 13:55:01.266 WARNING: [758] MediaSourceFactory.getSourceSsrcs#400: Unprocessed source groups: Optional[<ssrc-group xmlns='urn:xmpp:jingle:apps:rtp:ssma:0' semantics='SIM'/>```

This mostly happens because of websocket issue. Do you have any error in your browser console?

Thanks for your response. Yes, this is a web socket issue. How can I do that this problem? Is there any suggestion ?

Thanks.

There is a topic related in this issue.

2 Likes

Thanks for sharing this this worked for me too.

1 Like