Closed Captions not available for Guests in secure domain

Not sure when it happened but I have recently discovered that anonymous users are no longer getting an option for closed captions even after its enabled by a moderator. CC works fine for all the moderators that used JWT’s to start the meeting. I am sure its just a config issue but not sure what to look for here. I would like to just enable CC for all users regardless of JWT status.

No CC option for guests:


Moderator with CC working:

@damencho Do you remember any of this?

I did discover a slight problem where my jigasi was registered to a user in the Auth domain, the how to guide in Jigasi has this setup. I instead registered it to the same MUC as Jibri which resolved this in part. Now when the moderator enables CC, all the other users can see the option but I would like to do one of the following:

A) Show the CC button but have it greyed out until a moderator enables it. Maybe a tooltip with “Ask your moderator to turn on CC” This is more to let user’s know that its an option.

B) Allow all users to enable CC without the moderator first turning it on. I realize there is transcribing cost around this but it makes sense for Multilanguage schools where some users are better at reading the other language than listening through a multitude of accents.

You need UI changes for that.

UI changes for this and also you may need to do changes in jicofo as there is a check and in there.

1 Like

Before any convoluted or complex (sophisticated?) meeting to do translation on the fly by a group, in the analogue world would always would first do a dry run for around 15 - 20 minutes. This allowed for people to get used to the lag and to be comfortable with the fact they may not be able to give enough bandwidth (in their head) to being a participant - think foreign language live television shows, usually sport.

Having the CC button present and on stand-by greyed out agree with

Thanks.