Chrome doesn't enter to full screen mode

Hello

I try to record a 1280x720 video through Jibri. Recording work fine, but chrome doesn’t go to full screen. Record example from the jibri server:

The green frame above mean real video size 1280x720. But part of screen is black, so the main image is reduced.

I’ve tried to change chromeOptions, such as
–start-maximized
–window-size=1280x720
–kiosk
–start-fullscreen

this does not work for me

ffmpeg resolution is:
val resolution: String = “1280x720”,

xorg-video-dummy.conf Display part is:
Section “Screen”
Identifier “dummy_screen”
Device “dummy_videocard”
Monitor “dummy_monitor”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
Modes …
Virtual 1280 720
EndSubSection
EndSection

Package: google-chrome-stable
Version: 89.0.4389.114-1

chromedriver version: 89.0.4389.23

Help solve this, please

2 Likes

Sometimes, record starts with normal scale (but black block there) and after one second reduce the size:

next second:

1 Like

I found way to solve prolem.
[jibri src] I removed the “–start-maximized” flag and inserted “–window-size=1280,720” to chromeOptions.addArguments().
Only this options combination works in my case.

PS: window-size option uses “comma” not a “x”
PS2: use the two shot hyphen (-) before option name, this forum merges it to one long (–)

2 Likes

Hi! Where exactly did you change these parameters? Thanks!!

EDIT: Sorry, I figured out where to change these options: /etc/jitsi/jibri/jibri.conf