Changing the default language

Hello:

I have installed Jitsi Meet on my own Ubuntu server following the quick install guide and everything is ok.

Everything works correctly, both from web and from apps (ios and android).

Now I want the Spanish language by default.

To do this, in the file interface_config.js I wrote:

Line 32:

LANG_DETECTION: false, // Allow i18n to detect the system language

And in the file config.js

Line 244:

// Default language for the user interface.

Default language: ‘es’,

Finally, I have built and deployed.

However, the language still appears in english. Any ideas?

Thanks in advance.

It’s a known issue that should affect users that have visited the site before the default language changed on the server. If you use an incognito window, thereby simulating a first-time user, you should see the default language set to spanish.

Essentially when you first visited jitsi meet, you had your default language set to english on the server. When jitsi meet loaded, that language setting got stored in browser local storage. Then on follow up visits your language will keep showing up as english until you change it in the jitsi meet settings modal (or manually change your browser local storage).

However, if the default language is changed on the server and a new user visits, the default language will be set properly.

It’s an issue Damyan and I started looking into and he figured out the issue is somewhere within the library jitsi meet uses for i18n. https://github.com/jitsi/jitsi-meet/issues/3279#issuecomment-406586545

Thanks for your quick response.

I just tried from a window incognito and even from other devices and the english language still appears.

In an incognito window I can see it working fine through my local dev setup. On jitsi-meet I see it working too: https://meet.jit.si/testmeetingname#config.defaultLanguage=“es”. You’ll need to provide more information, such as your config. Make sure your config is loading defaultLanguage: “es”.

I can not understand why it still does not work. I reproduce the steps that I followed step by step:

Installation and basic configuration of Jitsi-Meet:

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -

sh -c “echo ‘deb https://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi-stable.list”

apt-get -y update

apt-get -y install jitsi-meet

cd /usr/share/jitsi-meet/scripts

./install-letsencrypt-cert.sh

nano -c /etc/jitsi/videobridge/sip-communicator.properties

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

/etc/init.d/jitsi-videobridge restart

Installation of NodeJs

curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -

sudo apt-get install -y nodejs

sudo apt-get install -y gcc g++ make

Default language change:

git clone https://github.com/jitsi/jitsi-meet.git

cd jitsi-meet/

nano -c config.js

uncomment the line:

// defaultLanguage: ‘en’,

and change "en" to "es".

npm install

make

rm -r /usr/share/jitsi-meet/

cp -r /home/xxx/jitsi-meet /usr/share

I could record a video with all the steps done if necessary.

1 Like

I think the first thing to do is you should verify config is loading the value you set. In your javascript console while on your jitsi-meet frontend deployment check the value of config; type “config” and press enter to see its values. The variable “config” becomes included into jitsi-meet as a server side include and left as a global variable. Alternatively look in your elements panel of the chrome inspector and look for where config is injected into the html.

I’m guessing if you check the value of config it’ll still be set to “en”. This is probably because config gets created/read in a location outside of /usr/share/jitsi-meet. For example, my config file for my dev instance is located in /etc/jitsi/meet.

There is no need of all the steps after Installation of NodeJs, you just nees to edit your config that is under /etc/jitsi/meet and that is all and all that Lenny already explained about the bug …

Now is working.

The problem was in the config file in /etc/jitsi/meet

Lenny8 & Damencho, many thanks for your help!

Is there somewhere a list of available languages, or any ISO 639-1 code is “valid” (if available)?

Hi …

What was the problem ? Because I uncommented the line “defaultLanguage” and tried a lot of other things I saw in some topics out there but nothing worked

Hi

I changed lang_detection to true, restarted my connection and it worked … but strangely every modification I make to “defaultLanguage” only takes effect after IP switching, even though it’s in anonymous mode

Hi.
Everybody solved translation UI in jitsi-meet?
Me not. I always have en UI.
I installed jitsi-meet to our Ubuntu server via quick-install, works fine. But I cannot force to translate jitsi-meet app UI. I configured:
/etc/jitsi/meet/meet.example.com-config.js
This config listen my changes except one:

defaultLanguage: ‘sk’,

I also configured:
/usr/share/jitsi-meet/interface_config.js
and again everything listen me except of

LANG_DETECTION: true,

I tried show app via iframe - API with

interfaceConfigOverwrite: { LANG_DETECTION: true },

and / with / or without

configOverwrite: { defaultLanguage: ‘sk’ },

and any combination of this two setups. Tried reboots services, tried reboot whole server. Nothing helped me. I always use incognito mode and many times with new browser and PC which has never visit my app. Every PC’s has setting up lang as ‘sk’.

I also cannot see my lang Slovak in UI user Setup selectbox. Neither in meet.jit.si

Could You please help me to debug why I cannot translate my App?
Thanks for any sugestion.

1 Like

Same for me - we translated jitsi to Lithuanian language, and copied main-lt.json and languages-lt.json to /usr/share/jitsi-meet/lang/ and to /usr/share/jitsi-meet/lang/languages.json added this line:
“lt”: “Lithuanian”,

Restarted jitsi server, but Lithuanian language doesn’t appear in user settings :frowning:

Same question here.
change it from ‘en’ to ‘zh’ or ‘zh-tw’, power-cycle the server, no change.

Hi there.
I finally find a way how translate my jitsi app.
Maybe this can help someone.

I did this steps:
From harder’s post Installed basic configuration, and install of nodeJs.
After that
I cloned jitsi-meet from github
cd jitsi-meet
edited lang/main-sk.json and translate all in it
translate languages-sk.json
add “sk”: “Slovakian” to all languages.json files
npm install
make
cd …
rm -r /usr/share/jitsi-meet/
mv jitsi-meet /usr/share/
edit /etc/prosody/conf.avail/MY-DOMAIN.cfg.lua and set correct path for prosody-plugins
plugin_paths = { "/usr/share/jitsi-meet/resources/prosody-plugins/" }
restart prosody, jicofo, jvb
…and Voilaa all is nice translated and my lang is now in offered languages.

1 Like