Changing Jigasi SIP Port

Hi all,

I am trying to setup Jigasi to talk to my Asterisk server, with SIP running on port 5070, but am running into some issues.

Here is my jigasi log:

2020-06-25 09:17:43.155 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
2020-06-25 09:17:43.155 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() net.java.sip.communicator.impl.notifications.eventType1593094662910.actions.actionType1593094662910.timeout=-1
2020-06-25 09:17:43.155 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jigasi.xmpp.acc.PASS=**********
2020-06-25 09:17:43.155 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
2020-06-25 09:17:43.313 WARNING: [36] org.jitsi.jigasi.xmpp.CallControl.().139 Always trust in remote TLS certificates mode is enabled
2020-06-25 09:17:43.386 INFO: [42] org.jitsi.jigasi.SipGateway.registrationStateChanged().120 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:310 AT 172.16.0.222) -> RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registering; userRequest=false; reasonCode=-1; reason=null]
2020-06-25 09:18:15.437 INFO: [37] org.jitsi.jigasi.SipGateway.registrationStateChanged().120 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:310 AT 172.16.0.222) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Connection Failed; userRequest=false; reasonCode=-1; reason=A timeout occurred while trying to connect to the server.]


And here is my sip-communicator.properties:

#Sample config with one XMPP and one SIP account configured
# Replace {sip-pass-hash} with SIP user password hash
# as well as other account properties
# Name of default JVB room that will be joined if no special header is included
# in SIP invite
org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=REDACTED
net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
# Should be enabled when using translator mode
#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioS>
# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
# Disables packet logging
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=172.16.0.222
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=5070
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP:310 AT 172.16.0.222
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=REDACTED
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=172.16.0.222
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=310 AT 172.16.0.222
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=600

From what I’ve read, these should be the only three lines I need to make Jigasi run on 5070, but it seems to be ignoring it.

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=172.16.0.222
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=5070

Anybody able to see what I’m missing?
Thanks!

The proxy protocol

Thanks
What would the directive be for that? I can’t seem to find it anywhere
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PROTOCOL=SIP ?

One of these:

.PREFERRED_TRANSPORT=TLS
.PREFERRED_TRANSPORT=TCP
.PREFERRED_TRANSPORT=UDP