Certifcate Error dectected

I am testing my Jisti Server and i am getting Certificate error in few PC accessed in the laptops which has policies different then the regular one. Like through organizational lapptops of my client

Any help how to overcome this issue . Do i need to modify the certificate ?

Error : Certificate error has occured on the website you requested and may not be secure.

Please guide

Thanks
Naveen

If you used self-signed certs during the install process these will not be trusted by others.

You need to either purchase and install a new ssl certificate or use the Let’s Encrypt script: sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

More help on this is in the Self-Hosting Guide from the handbook.

Thanks Corby . So do i need to just run this command and any thing i need to do in config or how does nginix pick this certificate .

Hi Corby

Can you guide me on the certificate I am still not able to get away with self signed certificate

Can I use certbot or the command you shared ? Is let’sencrypt also self signed

How do I close this

What are the steps how do I point yo let’s encrypt cert

I did run the command you shared but it’s not making any change

Do I need to make any changes any where

Pls guide

No.

If you installed with the self signed option then this script will do everything you need. It will ask for your email addresses, do the Http & Https challenge and put the certificates in the right place.

If that’s not what you see, can you post the output here.

I have done exactly the same. However when i run this in Mobile or for that matter any Performance testing tool like GTMETRIX etc i get an error Url:
(10061) No connection could be made because the target machine actively refused it.

Not Sure if its a different issue

This sounds different, but I am not sure.

Were there any errors when you ran that script?

Assuming the Let’s Encrypt cert process worked okay. Let’s start with the basics: First, can you access your meeting page from a browser using your domain (https://meet.mydomain.com) for example?

Is the cert fully trusted by the browser or does it complain? Does your Jitsi meet home page come up?

Try to provide as much information as you can about what you see and how far along you are. The community can help.

Hi Corby .

I am able to see my home page , use jitsi fully . But i am not able to run this in GTMetrix . I get this error

thanks
Naveen

The certificate is fully trusted by the browser

Could you test to run the following commands on a client

curl -s https://your.server.address/ | grep JITSI

wget -O - https://your.server.address/ | grep JITSI

I want to understand if there is a problem related in the SSL handshaking