Centos 8 install fails libappindicator needed

Hi,
I want to install jitsi remotely (ssh) on a (centos 8) server hosted in a datacenter.
Enabling the repo and running yum install jitsi fails with
Problem: cannot install the best candidate for the job - nothing provides libappindicator needed by jitsi-2.10-5550.x86_64 (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I was searching and trying to install libappindicator but couldn’t find a working method nor helps the advice given - to my understanding this library is used for desktop-notification-area (or something like that). A feature, that I clearly do not need, since the server won’t run any desktop software.

Is there a package/rpm or another way to just install the server components (not depending on libappindicator)?

You are trying to install Jitsi Destktop client, which is a desktop app.
If you want to install jitsi-meet meet, the instructions are https://jitsi.org/qi but we only support debian packages. There is a manual install doc, which you can use, but is not recommended and it is not a simple procedure and can go wrong on many places.

OK, i see … I was really not seeing that the link I followed was in the next section. Simple alienation of the packages didn’t work - You’re right manual installation is quite complex … Even thought of virtualization for my server to accomplish this… None of the ways is straightforward. Any ideas? Or are there any plans to provide rpms for the server stuff too, considering there are rpms for the desktop client?
I really like to have a working jitsi-meet on my server (which already is up and running and providing some services, so moving to debian is no option)

rpm is not an option for us, we tried and we cannot maintain it. Try this https://github.com/jitsi/docker-jitsi-meet/

1 Like

Up and running - thanks a lot for pointing me into the right direction …