Cant toggle and recording file failed to store on Jitsi server

I spinned up Jitsi meet docker with Jibri , everything seems to be work fine. However I started recording I cant toggle the “Save recording file locally (Beta)” and when I stop the recording, it downloads the recording file to my laptop. I want the files to be stored on the Jitsi docker server. Any idea what is going on?

You need Jibri for server-side recording.

yes, I do have Jibri docker container running but it doesn’t store the recording files in the /recordings folder , not much in the log though . Any other idea ?

According to the image you shared, the server-side recording is not enabled in your system.

Great! How can I enable it ? This is how I spinned up the Jitsi stack: (I’m using jitsi docker)
docker-compose -f docker-compose.yml -f etherpad.yml -f jigasi.yml -f jibri.yml up -d