Can't Show Stream Record

Hi master please help me,

I cant start record, i’m following this step “https://jitsi.org/downloads/
I start it in my aws but it fail to load stream record , whyyyyyy

you can see on 52.77.247.102 or attachment

Your deployment in general does not work. You have bosh connection configured as bosh: ‘//ip-172-31-17-44/http-bind’, which is not resolvable DNS.

1 Like

hmmm…
thats mean, i can’t used public ip?

No, but you just need to map a kind of domain or subdomain to this ip via a DNS-Record. So that you can use bosh: ‘//jitsi.domain.tld’, for example

1 Like

hi master i’ve done using domain not ip , but still problem

https://cangkruk.ipanel.id/

hmmmm that’s freak, can’t show stream

As far as i know you need to setup SSL on the Domain you’re using, since WebRTC-Streams won’t work with plain HTTP. So you need a https://-enabled host in your setup with a working certificate (like Let’s Encrypt).

excuse me , i’ve done installing ssl in my domain (cangkruk.ipanel.id)

but still have a problem, just 5second connect, and then error reconnecting
hmm help me master… thanks

What does your js consol logs say?

hmmm sorry i didn’t know

this is my site >>> “https://cangkruk.ipanel.id

So it complains about jicofo not in the room. Check jicofo logs?

I have not installed it, do I have to install it first?

jitsi-videobridge
jicofo
jigasi

i’m just only install jitsi-meet

You should be following https://jitsi.org/qi, and installing jitsi-meet installs all of those.

hi master, i already follow all step
and found this on “/var/log/jitsi/jicofo.log”

and i see something like this ini log “/var/log/jitsi/jvb.log”

You don’t have enough RAM, for default installation on one machine we recommend at least 8GB RAM.

hmm, now i’m set my RAM to 8GB

but still can’t stream

now i see this error log