Can't see each other, but can see oneself (not behind NAT)

I’m sorry to bring this very banal recurring issue, but I’ve been very unfortunate enough to fall in the category of people having the issue of being not able to see each other, but still can see themselves…

I’m not behind a NAT. Installation on a VPS/Ubuntu 16.0.4. I don’t see any of these: 10.x.x.x, or 172.16.x.x - 172.31.x.x, or 192.168.x.x

My firewall settings for Jitsi are as follow:

4443/tcp                   ALLOW       Anywhere
10000:20000/udp            ALLOW       Anywhere
80/tcp                     ALLOW       Anywhere
443/tcp                    ALLOW       Anywhere
4443/tcp (v6)              ALLOW       Anywhere (v6)
10000:20000/udp (v6)       ALLOW       Anywhere (v6)
80/tcp (v6)                ALLOW       Anywhere (v6)
443/tcp (v6)               ALLOW       Anywhere (v6)

I don’t know what to do since I don’t seem to be behind a NAT. I have even disabled the firewall on the VPS, but problem persists.

I must mention guests are still able to chat.

How can I be sure the whole thing is working properly on the server itself (other than testing installation from a remote computer using a browser)

Also, with regards to systemctl status – What stuff should I append to the command to know whether something is running or not? I tried systemctl status jitsi-meet, but no result. What processes can I check?

Also, I’ve got the following message in the browser log:

"[JitsiConference.js]" – "Failed to send E2E ping request or response." – undefined

Thanks for your help.

this setup is obsolete, should be only 10000. This is probably an indication that you have followed an old how to as well. The idea of your problem is that Jicofo and Prosody seem to work all right but videobridge2 is not. Try to read /var/log/jitsi/jvb.log.

Thank you. I also tried 1000/udp only.

OK, found this in the log:

java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.sctp.SctpManager
2020-06-22 21:27:05.449 WARNING: [28] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[not-authenticated] (0) closed with error

Here’s my videobridge config:

# Jitsi Videobridge settings

# sets the XMPP domain (default: none)

# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

# sets the port of the XMPP server (default: 5275)

# sets the shared secret used to authenticate to the XMPP server

# extra options to pass to the JVB daemon

# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS=" -Djava.util.logging.config.file=/etc/jitsi/videobridge/"

is it a recent message ? I have it in one of my logs but it was a month ago and it seems to have fixed itself. Are you sure your software is up to date (dpkg -l | grep jitsi) ?

Yes, it’s very recent message.

dpkg -l | grep jitsi
ii  jitsi-meet                             2.0.4627-1                                      all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody                     1.0.4127-1                                      all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-web                         1.0.4127-1                                      all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config                  1.0.4127-1                                      all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                     2.1-202-g5f9377b9-1                             all          WebRTC compatible Selective Forwarding Unit (SFU)

Could it be the fact I run Ubuntu 16.0.4? I’ve got nothing to upgrade.

The error message you mentioned seems to be nothing to worry about according to this GitHub post.

$ java -version
openjdk version "1.8.0_252"
OpenJDK Runtime Environment (build 1.8.0_252-8u252-b09-1~16.04-b09)
OpenJDK 64-Bit Server VM (build 25.252-b09, mixed mode)

this is not the same class, and it’s a very old message (2017). Your message points to a problem with SCTP, and short of you configuring Jitsi-meet to use websockets, SCTP is the way of communicating between JVB and workstations.

OK. I just followed the official guide to install Jitsi. A simple installation for two guests, the basic stuff. Just surprised to see how difficult it is to make Jitsi running even though after following the guide. I’m only doing basic installation. But, maybe it’s the Ubuntu version (16.0.4) I run as I only receive security patches. So, maybe the best thing is to upgrade the whole thing to the latest Ubuntu version.

I thank you for your comment, but you see, I don’t even know how to configure Jitsi-meet to use websockets as I did not find this in the official documentation.

Other than upgrading the OS, I’m stuck otherwise.

I don’t really advise you to try, as I tried it myself (not very hard) and gave up because I had other things to do and for now SCTP works (for me). Now that I think of it, SCTP is something a bit cheesy in Jitsi-meet since it relies on a native (that is not Java) library and it’s possible that some dependency could not be met on this older Ubuntu version, I recall dimly that people had said that some manual library install (with apt but outside of dependency link) could solve problems. I have found this very old post but it may have some relation.
Short of reinstalling you could try to setup a container. That’s what I do, my server is actually running Ubuntu 16.04 for now, and jitsi is setup in a LXD 20.04 container.

That’s a good idea indeed. Thanks for your valuable tip.

I decided to upgrade my Ubuntu from 16.04 to 18.04. I don’t know whether it solved my problem, because I no longer have any issue when the two guests use specific browsers. For example, when guest 1 and guest 2 use Vivaldi or Opera, they can see each other. However, if guest 1 uses Firefox and guest 2 uses Vivaldi, they no longer can see each other. So, in the end, what could be the problem? Is it still a server issue or a client side issue? And to make things even more complicated to debug, it’s when using this time: both guests can use any browser they like, be it Firefox, Opera, etc. So, from one side, it does not seem to be a server issue (guests use Vivaldi or Opera); from the other side, it’s a server issue since no problem at all with when using any browser.

you are running Debian stable version, don’t assume that does. I don’t know what they are running (that’s their concern) but I don’t think it’s Debian stable.

aha, never thought about this. Thanks for bringing this to my attention. And thanks a lot for your time.

OK, I’m not gonna push any further. So, my setup works well with guests using Chrome/Chromium, Vivaldi and Opera. I forget Firefox… However, I still have the following and only errors:

2020-06-28 14:09:55.872 SEVERE: [27] The invocation of the method threw an exception.

java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.videobridge.sctp.SctpManager

Just to know how I could clear this thing up. Otherwise, I’ll leave as it is.

I have not found anything else than this post for an explanation. If it does not work I have no other idea, sorry.

Hi, thanks for your time. In fact, my setup works fine. It’s difficult to find logs without error messages nowadays anyway. So, I’m happy with what I have. The result with Jitsi is nice.