Can't run jitsi-meet locally was working fine earlier

Hi,

I am using debian VM in Oracle virtual box !!

I was able to run jitsi-meet successfully until yesterday. I suddenly started getting the below errors.

Can anyone advise what’s wrong?

GET https://localhost:8080/libs/external_connect.js?v=1 net::ERR_EMPTY_RESPONSE
(index):589 GET https://localhost:8080/libs/lib-jitsi-meet.js?v=4046 net::ERR_EMPTY_RESPONSE
client:52 [WDS] Live Reloading enabled.
.web.js:5 Uncaught ReferenceError: JitsiMeetJS is not defined
at Module…/react/features/base/lib-jitsi-meet/
.web.js (.web.js:5)
at webpack_require (bootstrap:19)
at Module…/react/features/base/lib-jitsi-meet/index.js (index.js:1)
at webpack_require (bootstrap:19)
at Module…/react/features/analytics/functions.js (functions.js:3)
at webpack_require (bootstrap:19)
at Module…/react/features/analytics/index.js (index.js:1)
at webpack_require (bootstrap:19)
at Module…/react/features/base/conference/actions.js (app.bundle.js?v=4046:220577)
at webpack_require (bootstrap:19)
./react/features/base/lib-jitsi-meet/
.web.js @ _.web.js:5
webpack_require @ bootstrap:18
./react/features/base/lib-jitsi-meet/index.js @ index.js:1
webpack_require @ bootstrap:18
./react/features/analytics/functions.js @ functions.js:3
webpack_require @ bootstrap:18
./react/features/analytics/index.js @ index.js:1
webpack_require @ bootstrap:18
./react/features/base/conference/actions.js @ app.bundle.js?v=4046:220577
webpack_require @ bootstrap:18
./react/features/base/conference/index.js @ index.js:1
webpack_require @ bootstrap:18
./react/features/app/actions.js @ actions.js:5
webpack_require @ bootstrap:18
./react/features/app/index.js @ index.js:3
webpack_require @ bootstrap:18
./react/features/base/known-domains/middleware.js @ middleware.js:3
webpack_require @ bootstrap:18
./react/features/base/known-domains/index.js @ index.js:1
webpack_require @ bootstrap:18
./react/features/base/config/actions.js @ actions.js:5
webpack_require @ bootstrap:18
./react/features/base/config/index.js @ index.js:1
webpack_require @ bootstrap:18
./react/features/base/jwt/functions.js @ functions.js:3
webpack_require @ bootstrap:18
./react/features/base/jwt/index.js @ index.js:1
webpack_require @ bootstrap:18
(anonymous) @ AuthHandler.js:1
./modules/UI/authentication/AuthHandler.js @ app.bundle.js?v=4046:5349
webpack_require @ bootstrap:18
(anonymous) @ connection.js:1
./connection.js @ app.bundle.js?v=4046:3167
webpack_require @ bootstrap:18
(anonymous) @ conference.js:1
./conference.js @ app.bundle.js?v=4046:2958
webpack_require @ bootstrap:18
./app.js @ app.js:1
webpack_require @ bootstrap:18
0 @ app.bundle.js?v=4046:295958
webpack_require @ bootstrap:18
(anonymous) @ bootstrap:82
(anonymous) @ bootstrap:83
Show 13 more frames
client:52 [WDS] Live Reloading enabled.

Yes me too …

Same here.

This is not a solution but it can be used as a hack to continue your development process.
Copy paste libs/lib-jitsi-meet.min.js as libs/lib-jitsi-meet.js.

1 Like

Ok thanks . … :+1:

same here…

I had already tried that before posting this issue on forum and that didn’t work either !!

after you run ‘make dev’ commend then goto libs/ folder and change the name ‘lib-jitsi-meet.min.js’ to ‘lib-jitsi-meet.js’ and refresh the browser again. It works for me

1 Like

It worked when i renamed. It wasnt working when i copied .min.js to min.js

One more question, are you able to show the conference timer on the browser ?

No bro … its not working . If i found how to enable it i will put a message to you

Ok thanks… !!

and me

I used our hack but css not coming properly any solution for that?

Remove node_modules and install them again. This worked like a charm for me without any hacks :wink:.