Can't recording(jitsi, meet, jibri)

Please help me.

Follow thread Jibri not working - #11 by Prashanth

It is for the same issue…

Thanks for your kindly response @Prashanth. Actually, I don’t know well about jitsi and jibri.
I separated jitsi and jibri servers, where should I install java? jitsi or jibri?

Java8 should be installed on jibri server.

I installed but not working yet…

By the way, can you explain more detail about “Users jibri and recorder registered in Prosody” ?


about is prosody check status image. is it right status?
Almost domains are not resolved, but I can ping.

Not sure what document you followed for installation. Make sure you have done all the things mentioned in GitHub - jitsi/jibri: Jitsi BRoadcasting Infrastructure

If you are not familiar with jitsi and Jibri, may be the first thing is to install everything on the same system and once comfortable, may be then proceed to installing on different servers.

i did exactly that, it works (jibri+jitsi) if installed on one machine, but jibri wont work if i install it on seperate VM.

I followed many tutorials even on github wich wont explain key details needed to install jibri,and still wont work.
Tried on:
Ubuntu 16.04
Ubuntu 18.04
Ubuntu 18.04 server
Ubuntu 20.04
Ubuntu 20.04 server

same results. jibri wont start recording.

2021-05-01 17:31:18.600 INFO: [43] org.jitsi.jibri.api.xmpp.XmppApi.log() Sending 'pending' response to start IQ
2021-05-01 17:31:18.612 INFO: [55] org.jitsi.jibri.selenium.pageobjects.HomePage.log() Visiting url https://192.168.0.35/conference
2021-05-01 17:31:18.823 INFO: [55] org.jitsi.jibri.selenium.pageobjects.HomePage.log() Waited 206ms for driver to load page
2021-05-01 17:31:18.853 SEVERE: [55] org.jitsi.jibri.selenium.JibriSelenium.log() An error occurred while joining the call
org.openqa.selenium.WebDriverException: <unknown>: Failed to read the 'localStorage' property from 'Window': Access is denied for this document.
  (Session info: chrome=90.0.4430.93)
  (Driver info: chromedriver=90.0.4430.24 (4c6d850f087da467d926e8eddb76550aed655991-refs/branch-heads/4430@{#429}),platform=Linux 5.8.0-50-generic x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: 'unknown', revision: 'unknown', time: 'unknown'
System info: host: 'Ubuntu20VM', ip: '127.0.1.1', os.name: 'Linux', os.arch: 'amd64', os.version: '5.8.0-50-generic', java.version: '1.8.0_292'
Driver info: org.openqa.selenium.chrome.ChromeDriver
Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 90.0.4430.24 (4c6d850f087da..., userDataDir: /tmp/.com.google.Chrome.h82vvK}, cssSelectorsEnabled: true, databaseEnabled: false, goog:chromeOptions: {debuggerAddress: localhost:36907}, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), rotatable: false, setWindowRect: true, strictFileInteractability: false, takesHeapSnapshot: true, takesScreenshot: true, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unexpectedAlertBehaviour: ignore, unhandledPromptBehavior: ignore, version: 90.0.4430.93, webStorageEnabled: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true}
Session ID: 203fa597e4b5ca17069b7545010bab19

Did you open port 5222/tcp on the Jitsi VM?

Yeah all the ports were open, i dont know where was the problem, but i used Ark74 script to install jibri-node on a fresh VM and it worked. I just needed to set dpkg-reconfigure xserver-xorg-legacy to anybody since im using VM with desktop ubuntu installation.

So for any other noob to find this be sure to give kudos to Ark74 and visit GitHub - switnet-ltd/quick-jibri-installer: Bash installer for Jitsi Meet along with Jibri on *buntu LTS based systems | Documentation Available at the Wiki