Can't open up camera and mic after installing with static IP

I have had installed Jitsi with static IP (not with domain name), and it was working(even though we got security warning when first entering to the website). Now I installed again,
sudo apt -y install jitsi-meet
in the installation I entered the IP address of the server and told to Generate a self signed certificate.


After installation, I can enter to the website but I can’t open up camera. The camera seems to be working(the light is turned on) but no video on the screen and the camera and mic buttons not working.
image
Do I need to generate another certificate? But I didn’t generate a certificate last time I installed and it was working.
If the version has changed in the last month, how can I install previous version of Jitsi-meet?

JVB logs:
JVB 2021-06-03 16:45:24.909 WARNING: [161] [hostname=localhost id=shard] MucClient$1.connectionClosedOnError#277: Closed on error:
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:829)

Jicofo logs:
Jicofo 2021-06-03 16:46:23.697 WARNING: [243] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[not-authenticated] (0) closed with error
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:829)

Chrome Logs:
(TIME) index.html loaded: 193.59999990463257
Logger.js:154 2021-06-03T13:48:35.412Z [modules/browser/BrowserCapabilities.js] : This appears to be chrome, ver: 91.0.4472.77
LocalStatsCollector.js:22 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
Logger.js:154 2021-06-03T13:48:36.164Z [features/analytics] Initialized 0 analytics handlers
Logger.js:154 2021-06-03T13:48:36.166Z [features/base/media] Start muted:
Logger.js:154 2021-06-03T13:48:36.169Z [features/base/media] Start audio only set to false
Logger.js:154 2021-06-03T13:48:36.355Z [index.web] <HTMLDocument.>: (TIME) document ready: 1194.5999999046326
Logger.js:154 2021-06-03T13:48:36.416Z [modules/RTC/RTCUtils.js] list of media devices has changed: (8) [InputDeviceInfo, InputDeviceInfo, InputDeviceInfo, InputDeviceInfo, InputDeviceInfo, MediaDeviceInfo, MediaDeviceInfo, MediaDeviceInfo]
Logger.js:154 2021-06-03T13:48:36.476Z [modules/RTC/RTCUtils.js] Audio output device set to default
Logger.js:154 2021-06-03T13:48:36.568Z [modules/xmpp/xmpp.js] <P._initStrophePlugins>: P2P STUN servers: [{…}]
Logger.js:154 2021-06-03T13:48:36.590Z [modules/xmpp/xmpp.js] <P.connectionHandler>: (TIME) Strophe connecting: 1429.7999999523163
Logger.js:154 2021-06-03T13:48:36.599Z [modules/RTC/RTCUtils.js] <$.>: Got media constraints: {“video”:{“height”:{“ideal”:720,“max”:720,“min”:180},“width”:{“ideal”:1280,“max”:1280,“min”:320},“facingMode”:“user”},“audio”:{“autoGainControl”:true,“echoCancellation”:true,“noiseSuppression”:true}}
An unknown error occurred when fetching the script.
sasd:39 DOMException: Failed to register a ServiceWorker for scope (‘https://11.22.33.44/’) with script (‘https://11.22.33.44/pwa-worker.js’): An unknown error occurred when fetching the script.
Logger.js:154 2021-06-03T13:48:37.253Z [modules/RTC/RTCUtils.js] onUserMediaSuccess
Logger.js:154 2021-06-03T13:48:37.953Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Server did not yet offer a supported authentication mechanism. Sending a blank poll request.

Show 209 more frames
Logger.js:154 2021-06-03T13:48:38.052Z [features/base/redux] <Object.persistState>: redux state persisted. b672da2c39f902cccfc01bce15c055cb → 682e4b1651b91ef96648b1c063cb83fa

Try to purge all packages from the first installation and reinstall again. Probably there is some conflict between initial and final settings

I purged everything 3-4 times, I deleted /etc/jitsi and /etc/prosody directory(This gave me error saying /etc/prosody/certs/1.2.3.4.conf doesnt exist, I created /etc/prosody/certs directory by hand and it worked again).
sudo apt purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jicofo jitsi-videobridge2
I even purged nginx and nginx-common.

Don’t forget to purge prosody too

If the static IP is a private ip, add a dns entry in hosts file and use that for installing instead of IP…

Thanks a lot, purging prosody worked.
sudo apt-get purge prosody
And I purged apache2, apache2-bin, apache2-doc, apache2-utils, apache2-data, the error can be caused by those too, just writing for the future readers.
Thanks.

It was a public IP @Prashanth