Can't Install On 22.04LTS, No libssl1.1

E: Package ‘libssl1.1’ has no installation candidate

Looks like we will have to use a different distro until jitsi is rewritten to use sslv3.

We are aware of this issue and will be addressing it in the following weeks.

That package existed in the images we tested before the 22.04 release and was dropped later :man_shrugging:

Oddly, jitsi-videobridge will install as it does not have that dependency. It is jitsi-videobridge2 that fails to install.

This got me curious, what for exactly is Jitsi-meet needing openssl ? It turns out that openssl (the crypto part, for AES encryption) is used by the jitsi-srtp project to accelerate the handling of srtp (video streams).

So in fact Jitsi-meet still uses native libraries, even after the deprecating of sctp. IIUC the difference is that when native support is not available, jitsi-srtp can fallback to a Java implementation, so jitsi-meet can still be used on a non-x86 processor (supporting Java of course)

Native openssl3 support for srtp was added yesterday, so a fix to packaging should not be too far in the future.

jitsi-videobridge is not an alternative to jitsi-videobridge2, it’s deprecated since a long time.

I understand that jitsi-videobridge is deprecated. I was surprised that it would build and the current one would not.

I have fallen back to Ubuntu 21.10 until this is sorted out.

This had been fixed in the latest packages from the unstable repo.

yes I just tested and it installs fine (minus coturn of course but we know that).
FTR it installs Prosody 11.13 as it’s the version released with the distro.

Is the fix in stable yet?

For sure