Can't hear or see each other

Hello Everyone, this issue has been discussed before but I’ve tried every solution and none worked!

So last week I updated jitsi something that I didnt do from the last june, and all of a sudden Jitsi stopped working.the issue is that if I try and connect with anyone (two or more people) I can’t see or hear him/them and the same for him/them.

My ports are open
To Action From
– ------ ----
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
10000/udp ALLOW Anywhere
22/tcp ALLOW Anywhere
5349/tcp ALLOW Anywhere
3478/udp ALLOW Anywhere
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
10000/udp (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6)
5349/tcp (v6) ALLOW Anywhere (v6)
3478/udp (v6) ALLOW Anywhere (v6)

and I did the following advanced configuration step >
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=127.0.0.1
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=2xx.xxx.xxx.xxx

any help would be much appreciated.

try this:

(server)
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u
(workstation)
echo "123" | nc -u (your public address) 10000

you should see 123 appear on your server’s console. If not you have a network proiblem, check firewall at all levels.

My console can see messages just fine

oh well, I had not read your post carefully enough and missed that your server worked before the upgrade. Shame on me. In this case it could be some config file problem. What has changed in the mean time ? Basically Jitsi has got rid of the nginx ssl preread feature. It could possibly be some problem in the http server (nginx) config file then. Maybe try to post the site file (yourdomain.conf) and the jvb log (or the end of the jvb log after the last restart if it’s too big)

No worries sir, thank you for taking the time to help me.

So what happened is I updated Jitsi and the whole server last week and then I enabled Apache2 on a different port then 3 days ago I was running a call with 2 partners of mine and we couldn’t hear or see each other, I do remember this issue existing before and I solved it by adding the ice4j lines (they were already there after the update) I tried every possible solution and none worked so I decided to do reinstall the whole server and then change webmin’s portal and then install nginx and then install jitsi and open ports and do the advanced config step but still nothing.

here’s the doman conf file found in nginx
mydomain.txt (4.1 KB)
changed the domain name to mydomain

EDIT: forgot to attach the jvb log sorry
jvb.log.txt (417.2 KB)

the output as root?

dpkg -l 'jitsi-*'
ls -alh /etc/nginx/modules-enabled/
netstat -taunp

dpkg -l ‘jitsi-*’ output:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  jitsi-meet     2.0.5142-1   all          WebRTC JavaScript video conferenc
ii  jitsi-meet-pro 1.0.4466-1   all          Prosody configuration for Jitsi M
un  jitsi-meet-tok <none>       <none>       (no description available)
un  jitsi-meet-tur <none>       <none>       (no description available)
ii  jitsi-meet-web 1.0.4466-1   all          WebRTC JavaScript video conferenc
ii  jitsi-meet-web 1.0.4466-1   all          Configuration for web serving of
un  jitsi-videobri <none>       <none>       (no description available)
ii  jitsi-videobri 2.1-376-g9f1 all          WebRTC compatible Selective Forwa

ls -alh /etc/nginx/modules-enabled/ output

total 16K
drwxr-xr-x 2 root root 4.0K Nov 22 19:58 .
drwxr-xr-x 8 root root 4.0K Nov 22 19:58 ..
lrwxrwxrwx 1 root root   54 Nov 22 19:58 50-mod-http-geoip.conf -> /usr/share/nginx/modules-available/mod-http-geoip.conf
lrwxrwxrwx 1 root root   61 Nov 22 19:58 50-mod-http-image-filter.conf -> /usr/share/nginx/modules-available/mod-http-image-filter.conf
lrwxrwxrwx 1 root root   60 Nov 22 19:58 50-mod-http-xslt-filter.conf -> /usr/share/nginx/modules-available/mod-http-xslt-filter.conf
lrwxrwxrwx 1 root root   48 Nov 22 19:58 50-mod-mail.conf -> /usr/share/nginx/modules-available/mod-mail.conf
lrwxrwxrwx 1 root root   50 Nov 22 19:58 50-mod-stream.conf -> /usr/share/nginx/modules-available/mod-stream.conf

netstat -taunp output

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      14172/lua5.1
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      534/mysqld
tcp        0      0 0.0.0.0:9999            0.0.0.0:*               LISTEN      16812/perl
tcp        0      0 127.0.0.1:8080          0.0.0.0:*               LISTEN      23334/java
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      14613/nginx: master
tcp        0      0 0.0.0.0:5269            0.0.0.0:*               LISTEN      14172/lua5.1
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      406/systemd-resolve
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      448/sshd
tcp        0      0 0.0.0.0:8888            0.0.0.0:*               LISTEN      14276/java
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      14613/nginx: master
tcp        0      0 0.0.0.0:5280            0.0.0.0:*               LISTEN      14172/lua5.1
tcp        0      0 0.0.0.0:9090            0.0.0.0:*               LISTEN      23334/java
tcp        0      0 127.0.0.1:5347          0.0.0.0:*               LISTEN      14172/lua5.1
tcp        0      0 127.0.0.1:5222          127.0.0.1:43270         ESTABLISHED 14172/lua5.1
tcp        0      0 127.0.0.1:45078         127.0.0.1:5347          ESTABLISHED 14276/java
tcp        0      0 127.0.0.1:5222          127.0.0.1:42332         ESTABLISHED 14172/lua5.1
tcp        0      0 127.0.0.1:43270         127.0.0.1:5222          ESTABLISHED 23334/java
tcp        0      0 2xx.xxx.xxx.xxx:22      93.95.240.245:54522     ESTABLISHED 24113/sshd: root [p
tcp        0      0 127.0.0.1:42332         127.0.0.1:5222          ESTABLISHED 14276/java
tcp        0     41 2xx.xxx.xxx.xxx:22      189.58.144.15:59969     ESTABLISHED 24115/sshd: [accept
tcp        0      0 2xx.xxx.xxx.xxx:52448   79.143.183.106:80       TIME_WAIT   -
tcp        0      0 2xx.xxx.xxx.xxx:22      218.92.0.210:42177      SYN_RECV    -
tcp        0      0 127.0.0.1:5347          127.0.0.1:45078         ESTABLISHED 14172/lua5.1
tcp        0    272 2xx.xxx.xxx.xxx:22      156.221.140.156:50082   ESTABLISHED 23901/sshd: root@pt
tcp        0      0 2xx.xxx.xxx.xxx:80      142.44.145.51:63687     SYN_RECV    -
tcp6       0      0 :::5222                 :::*                    LISTEN      14172/lua5.1
tcp6       0      0 :::80                   :::*                    LISTEN      14613/nginx: master
tcp6       0      0 :::5269                 :::*                    LISTEN      14172/lua5.1
tcp6       0      0 :::22                   :::*                    LISTEN      448/sshd
tcp6       0      0 :::443                  :::*                    LISTEN      14613/nginx: master
tcp6       0      0 :::5280                 :::*                    LISTEN      14172/lua5.1
udp        0      0 0.0.0.0:57055           0.0.0.0:*                           14276/java
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           16812/perl
udp        0      0 127.0.0.53:53           0.0.0.0:*                           406/systemd-resolve

I hid the server ip if this is an issue i’ll send it privately to you

UDP/10000 is used by a perl process, webmin?

I changed webmin’s port its configuration file to a different port

and back when I had jitsi working webmin was on the same port

EDIT found this in the webmin config module should i disable it

sure it can’t work if another process it taking port 10000. You can change the port used by jvb by setting something like
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=10001
in
/etc/jitsi/videobridge/sip-communicator.properties
If you do that you have of course to take care of firewall issues.

1 Like