Cant get mod_muc_size working, request returns 404

Hello everyone,

For the past few days i’ve been trying to get mod_muc_size to work on prosody but without any success.
I have added muc_size to my modules_enabled, added a line that logs and it loads just fine, but it doesnt route to the proper functions. Whenever i try to request to http://127.0.0.1:2580/sessions I get a 404.

Bosh seems to be working, for when I go to http:127.0.0.1:2580/http-bind I do get the BOSH page.
The only error I am getting in my prosody log is the fact that there is no certificate for the port 2581, but that shouldn’t be the issue.

Seeing as I can’t find my solution online, I thought i’d try posting here. Would anyone have any idea what i’m missing? are there any steps besides adding the module I need to take for it to listen to the requests?

I have hidden the domain name for security reasons.


VirtualHost "[DOMAINNAME]"
    -- enabled = false -- Remove this line to enable this host
    authentication = "token"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    app_id="ID"
    app_secret="SECRET"
    allow_empty_token = false
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/[DOMAINNAME].key";
        certificate = "/etc/prosody/certs/[DOMAINNAME].crt";
    }
    speakerstats_component = "speakerstats.[DOMAINNAME]"
    conference_duration_component = "conferenceduration.[DOMAINNAME]"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "presence_identity";
        "muc_size";
    }
    muc_mapper_domain_prefix = "muc"
    c2s_require_encryption = false
    lobby_muc = "lobby.[DOMAINNAME]"
    main_muc = "conference.[DOMAINNAME]"
    -- muc_lobby_whitelist = { "recorder.[DOMAINNAME]" } -- Here we can whitelist jibri to enter lobby enabled rooms

Thanks in advance.

@sebasvdonk welcome to the community!

The config looks okay. You could check your log file (/var/log/prosody/prosody.log) for any errors or info about muc_size when Prosody is starting up.

This post may also help: Get the list of rooms - #110 by simonf

By the way, we typically use port 5280 maybe 2580 was a typo or something custom you setup?

Hey @corby thanks for the reply, 2580 was indeed a typo, and I have managed to fix the issue. The problem was that I was doing calling my localhost (127.0.0.1) instead of my domainname. Silly mistake!