Can't get jibri to start recording

Hi,

I’m trying to get jibri to work, but until now I’m unsuccessful. Most of the times Google is my friend and eventually i can get the answer I’m looking for somewhere, but now I’m completely clueless.

I’ve tried many (video) tutorials, tried different OS’es, tried running jibri and jitsi on different servers, on the same server, did many re-installs but it all results in the same error message: “Recording failed to start”.

OS’es I’ve tried: Ubuntu 16 / Ubuntu 20 / Debian 10 (current install, jitsi and jibri on the same server)
So I’m out of ideas right now. Checking the logs does not help me anymore at this point; i can see no real errors in there. Maybe I’m not looking in the right place… It seems to me the “Recording failed to start” message should yield some log anywhere?

To verify if clicking “Start Recording” shows up in the logs, i did the following:

I cleared all the logs so no unnecessary messages from the setup / install procedures would be in it.
At 20:56 is started the server. I let it run without doing anything for +/- 15 minutes, to be sure that any events that would be triggered during setting op the call / recording tests had a very noticeable different timestamp.

I started a meeting called “TESTMEETING” at 21:10. For the same reason i mentioned before i let it run for 5 minutes before trying to make a recording, then i started clicking “record this call” continuously for a minute. At 21:16 i didn’t do anything anymore, and finally i left the chat at 21:18 (letting it rest for an additional two minutes).

I shared all the logs / configs / screenshots that may be relevant here: https://mycloud.homelinux.com/index.php/s/cdJotFAWWMjrE8e

The server has 8 cores (Intel Xeon, is a VM) and 32GB memory.

Any comments / advice pointing me to the right direction would be greatly appreciated. If there are additional logs or information needed i will be more than happy to provide this.

Thanks in advance!

Cheers,
René

Is there any log in /var/log/jitsi/jibri/

I meant ffmpeg.log

Yes, log.0.txt and xorg.log

Where can i find this? It’s not present in /var/log/

ffmpeg.0.txt and browser.0.txt should be in /var/log/jitsi/jibri/ if jibri tried to record something

Ok, unfortunately no logs there but:
root@meet:/var/log/jitsi/jibri# ls -la
total 128
drwxrwxr-x 2 root jitsi 4096 Oct 21 23:23 .
drwxrwx— 3 jvb jitsi 4096 Oct 21 21:08 …
-rw-r–r-- 1 jibri jibri 11931 Oct 21 23:36 log.0.txt
-rw-r–r-- 1 jibri jibri 0 Oct 21 23:23 log.0.txt.lck
-rw-r–r-- 1 jibri jibri 18510 Oct 21 21:58 log.1.txt
-rw-r–r-- 1 jibri jibri 41878 Oct 21 23:23 xorg.log
-rw-r–r-- 1 jibri jibri 41950 Oct 21 21:58 xorg.log.old

Your prosody.cfg.lua is different from the usual. I only add the recorder block in /etc/prosody/conf.d/mydomain.cfg.lua and no other changes

Ok ,i changed this. restarted prosody, and jibri but still no joy unfortunately…
I’d like to share my current prosody.cfg.lua configuration, but sharing a link to it or pasting it below gives me the error “Sorry, new users can only put 2 links in a post.”

Looking around i found another screenshot of a running jibri status, i saw there the jibri service starts the chromedriver:


My jibri service doesn’t:

My /opt/jitsi/jibri/launch.sh contains the following:
#!/bin/bash

exec /usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -Dconfig.file="/etc/jitsi/jibri/jibri.conf" -jar /opt/jitsi/jibri/jibri.jar --config “/etc/jitsi/jibri/config.json”