Can't find Lobby Feature

Hi,
I’ve been editing some things on Jitsi but when looking to see on security features, I do not see lobby there? Anyone know why and how to fix that?

Share your cfg.lua configuration

Where would you find that file?

I’m not sure where that would be?

Check in /etc/prosody/conf.avail/

Doesn’t look like I have that file… hmmm…

Here is the live link if you wanted to see: https://meet.calyr.online/test

Looks like it’s not there…

How did you install Jitsi?
Checked out your site - looks like your customizations may be hiding the lobby button.

Oh… I see… Do you know what I should do?

I’m not really sure where to go to fix that

Well, we need to find your prosody lua file to make sure lobby is enabled, for one. Again, how did you install Jitsi? What guide did you use?

So I did the quick install but I changed up the stuff needed by cloning the Repo for Jitsi-meet then implementing my changes to the server who has the reuglar Jitsi-Meet then did npm install and make

I also did find this:

image

OH WAIT! I found it!

You need to find a file called meet.calyr.online.cfg.lua

Yes I found it sending the code now

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "meet.calyr.online";

turncredentials_secret = "O9cIVA2EpnxExZNK";

turncredentials = {
  { type = "stun", host = "meet.calyr.online", port = "3478" },
  { type = "turn", host = "meet.calyr.online", port = "3478", transport = "udp" },
  { type = "turns", host = "meet.calyr.online", port = "5349", transport = "tcp" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

-- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
ssl = {
  protocol = "tlsv1_2+";
  ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
}

VirtualHost "meet.calyr.online"
        -- enabled = false -- Remove this line to enable this host
        authentication = "anonymous"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/meet.calyr.online.key";
                certificate = "/etc/prosody/certs/meet.calyr.online.crt";
        }
        speakerstats_component = "speakerstats.meet.calyr.online"
        conference_duration_component = "conferenceduration.meet.calyr.online"
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "speakerstats";
            "turncredentials";
            "conference_duration";
            "muc_lobby_rooms";
        }
        c2s_require_encryption = false
        lobby_muc = "lobby.meet.calyr.online"
        main_muc = "conference.meet.calyr.online"
        -- muc_lobby_whitelist = { "recorder.meet.calyr.online" } -- Here we can whitelist jibri to enter lobby enabled rooms

Component "conference.meet.calyr.online" "muc"
    storage = "none"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
    }
    admins = { "focus@auth.meet.calyr.online" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.meet.calyr.online" "muc"
    storage = "none"
    modules_enabled = {
      "ping";
    }
    admins = { "focus@auth.meet.calyr.online", "jvb@auth.meet.calyr.online" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.meet.calyr.online"
    ssl = {
        key = "/etc/prosody/certs/auth.meet.calyr.online.key";
        certificate = "/etc/prosody/certs/auth.meet.calyr.online.crt";
    }
    authentication = "internal_plain"

Component "focus.meet.calyr.online"
    component_secret = "NYd41QsJdLQWHQ43"

Component "speakerstats.meet.calyr.online" "speakerstats_component"
    muc_component = "conference.meet.calyr.online"

Component "conferenceduration.meet.calyr.online" "conference_duration_component"
    muc_component = "conference.meet.calyr.online"

Component "lobby.meet.calyr.online" "muc"
    storage = "none"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true

There you go :slight_smile:

Were you able to look into it?

Lobby is working only on prosody 0.11+, I suspect this is your problem.