Can't enable guest to join conferences without account

Hi.
I have setup jitsi meet to internal authentication and now every user need to write login account data.

VirtualHost "conference.mysite.com"
    authentication = "internal_plain"

But when I add

b) Add new virtual host with anonymous login method for guests:

VirtualHost "conference.mysite.com"
    authentication = "anonymous"
    c2s_require_encryption = false

(Note that guest.jitsi-meet.example.com is internal to jitsi, and you do not need to (and should not) create a DNS record for it, or generate an SSL/TLS certificate, or do any web server configuration.)

NOTE: Make sure you enable desired modules to the guest virtual host like turncredentials (if you use STUN/TURN together with secure domain) and/or conference_duration etc., by adding the modules_enabled option:

VirtualHost "guest.conference.mysite.com"
    authentication = "anonymous"
    modules_enabled = {
     "turncredentials";
    }
    c2s_require_encryption = false

Jitsi stop to works completely.

in the conference.mysite.com.cfg.lua I added at the bottom:

VirtualHost "guest.jitsi-meet.example.com"
    authentication = "anonymous"
    modules_enabled = {
     "turncredentials";
    }
    c2s_require_encryption = false

and in the /etc/jitsi/meet/conference.mysite.com-config.js)

            anonymousdomain: 'guest.conference.mysite.com',

Where I am wrong?

After verify the code, i have correct an error but
now the system don’t ask anymore for user authentication for rooms creation.

the problem is ```
guest.conference.mydomain.com


if i disable this it ask for login to create a new meeting.

I have the same problem like you stated, how could you fix it? I do not understand your fix