Can't dial numbers preceded by a plus +1

sip
#1

I am trying to dial out using a FreePBX SIP system and when I dial a number with a +1 (Canada and US country code,) it never completes the call and the dialing window just closes. I’ve not had this issue with other SIP clients and was wondering if there was just a setting I was missing?

#2

Ups this is for jitsi desktop. Have you checked the logs?

#3

Hi Damencho,

This is for the Jitsi desktop app.
I did just look at the logs, but they are just coming back with call failed:
[](file:///C:/Users/x/AppData/Roaming/Jitsi/history_ver1.0/callhistory/default/default/1557414352873.xml#)SIP:2819@voip.redacted2019-05-09T19:09:30.549-06002019-05-09T19:09:30.549-0600out+14039097125@voip.redacted2019-05-09T19:09:30.549-06002019-05-09T19:09:30.549-0600Failed-1"+14039097125"

That is the log file in appdata\roaming\jitsi\history_ver1.0\callhistory\default\default

I found the other log in appdata\local, but it doesn’t really tell me much, but maybe they’ll help you to point me in the right direction:
2019-05-10 11:45:21.291 INFO: [24318] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:+14039097125@voip.redacted
2019-05-10 11:45:21.314 INFO: [24318] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy redacted:5060/UDP as hop instead of an address resolved by the SIP router
2019-05-10 11:45:21.352 INFO: [24376] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /redacted:5060
2019-05-10 11:45:21.353 INFO: [24376] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy redacted:5060/UDP as hop instead of an address resolved by the SIP router
2019-05-10 11:45:21.360 INFO: [24392] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /redacted:5060
2019-05-10 11:45:21.361 SEVERE: [24392] impl.protocol.sip.OperationSetBasicTelephonySipImpl.processResponse().634 Received error: 404 Not Found

Thank you for taking a look at this!

James Carlisle

#4

Seems you get a response 404 for this number

#5

Right, but if I dial the number without the +, it works. Also, if I use another application, it works without issue.
I’m not sure why Jitsi is failing but other SIP applications work when dialing a number with a + at the beginning.

#6

These needs a check on the sip side, or comparing tcpdumps of successful and unsuccessful call with +… Cannot guess why server responds with 404.