Can't connect to meeting - New install of Jitsi Meet

Jitsi Meet front page displays and I can go to a meeting page, but none of it works:

  • My indicator light on my webcam turns on, but there’s no video on screen. (Video preview can been seen in settings.)
  • Mic and camera buttons indicate off, and do nothing when clicked.
  • After 30-40 seconds, I get “You have been disconnected” message. It repeats 30-40 seconds after each reconnect.
  • “You are the only one in the meeting” message remains after I try to join meeting on another machine. Second machine also has the other symptoms.

Clients are Chromebooks that successfully used other Jitsi Meet instances.

I tested UDP 10000 connectivity from another machine on same home network following these instructions and the test message was received.

Server is running Debian 9.

bash history from installing
1  mkdir ~/log
2  apt-get update ; apt-get dist-upgrade -y
3  tasksel install standard
4  apt-get install gnupg2 apache2 sudo apt-transport-https wget ufw >> ~/log/apt.log
5  less log/apt.log 
(It had been taking a while so I stopped and checked redirected output. It looked normal so I uninstalled and installed again.)
6  apt-get purge --autoremove gnupg2 apache2 sudo apt-transport-https wget ufw
7  apt-get install gnupg2 apache2 sudo apt-transport-https wget ufw
8  hostnamectl set-hostname d1
9  wget https://download.jitsi.org/jitsi-key.gpg.key
10  view jitsi-key.gpg.key
11  apt-key add jitsi-key.gpg.key
12  echo 'deb  https://download.jitsi.org stable/' >>/etc/apt/sources.list.d/jitsi-stable.list
13  apt update
14  sudo ufw allow 80/tcp
15  sudo ufw allow 443/tcp
16  sudo ufw allow 10000/udp
17  sudo ufw allow 22/tcp
18  sudo ufw allow 3478/udp
19  sudo ufw allow 5349/tcp
20  sudo ufw enable
21  sudo ufw status verbose
22  apt install jitsi-meet
23  /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Errors and warnings spotted in logs:

/var/log/jitsi/jvb.log Repeating warning

2020-12-20 10:53:30.477 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime: A provider org.jitsi.rest.Version registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint configuration problems the provider org.jitsi.rest.Version will be ignored.

/var/log/jitsi/jvb.log "Severe" error only appeared once

2020-12-19 20:57:08.122 SEVERE: [29] RetryStrategy$TaskRunner.run#198: org.jivesoftware.smack.SmackException$AlreadyLoggedInException: Client is already logged in
org.jivesoftware.smack.SmackException$AlreadyLoggedInException: Client is already logged in
at org.jivesoftware.smack.tcp.XMPPTCPConnection.throwAlreadyLoggedInExceptionIfAppropriate(XMPPTCPConnection.java:371)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:487)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:448)
at org.jitsi.xmpp.mucclient.MucClient.lambda$getConnectAndLoginCallable$7(MucClient.java:681)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

/var/log/jitsi/jicofo.log Warnings today

Jicofo 2020-12-20 10:53:27.893 WARNING: [12] org.jitsi.jicofo.FocusManager.log() Jicofo ID is not set. Configure a valid value [1-65535] by setting org.jitsi.jicofo.SHORT_ID. Future versions will require this for Octo.
Jicofo 2020-12-20 10:53:27.924 WARNING: [12] org.jitsi.jicofo.FocusManager.log() No dedicated JVB MUC XMPP connection configured - falling back to the default XMPP connection
Jicofo 2020-12-20 10:53:29.918 WARNING: [18] org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.log() Failed to discover features for conferenceduration.d1.josephrobarts.com: XMPP error reply received from conferenceduration.d1.josephrobarts.com: XMPPError: service-unavailable - cancel
Jicofo 2020-12-20 10:53:29.929 WARNING: [18] org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.log() Failed to discover features for focus.d1.josephrobarts.com: XMPP error reply received from focus.d1.josephrobarts.com: XMPPError: service-unavailable - wait
Jicofo 2020-12-20 10:53:29.933 WARNING: [18] org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.log() Failed to discover features for speakerstats.d1.josephrobarts.com: XMPP error reply received from speakerstats.d1.josephrobarts.com: XMPPError: service-unavailable - cancel
Jicofo 2020-12-20 10:53:34.459 WARNING: [30] org.jitsi.config.log() Key ‘jicofo.bridge.average-participant-packet-rate-pps’ from source ‘typesafe config’ is deprecated: use jicofo.bridge.average-participant-stress

/var/log/prosody/prosody.log Repeating errors and warnings today
Dec 20 10:53:19 certmanager error SSL/TLS: Error initialising for *: invalid protocol (tlsv1_2+)
Dec 20 10:53:19 modulemanager error Unable to load module ‘storage_memory’: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory
Dec 20 10:53:19 storagemanager error Failed to load storage driver plugin memory on conference.d1.josephrobarts.com: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory
Dec 20 10:53:19 storagemanager warn Falling back to null driver for persistent storage on conference.d1.josephrobarts.com

I’m guessing that these ones are important:

Jicofo 2020-12-20 10:53:27.893 WARNING: [12] org.jitsi.jicofo.FocusManager.log() Jicofo ID is not set. Configure a valid value [1-65535] by setting org.jitsi.jicofo.SHORT_ID. Future versions will require this for Octo.
Jicofo 2020-12-20 10:53:27.924 WARNING: [12] org.jitsi.jicofo.FocusManager.log() No dedicated JVB MUC XMPP connection configured - falling back to the default XMPP connection

In /etc/jitsi/videobridge/config, I changed

JVB_OPTS="–apis=,"

to

JVB_OPTS="–apis=,xmpp"

per this post and restarted the server, but didn’t see any changes in symptoms or errors. The log exerts above were from before I did that, but a glance at new logs didn’t look different. Disabling ufw didn’t change symptoms either.

Would any other info be helpful?

Seems like many issues with your deployment. A new installation on a more recent distro (for example Debian 10) will be better

1 Like

Oops! Looks like I didn’t install openjdk.

@emrah Thanks for the quick reply! It made me remember that the self-hosting guide said some dependency was more complicated to get on Debian 10 than Debian 9, which is why I used 9 instead of 10. But I missed installing it at all.
I’ll try installing openjdk-8-jdk see if that fixes it. If not, I’ll try Debian 10 as you suggest. Thanks! :slight_smile:

if you use it, do not follow the guide advising to install adoptopenjdk. Use java from the standard repos (Java 11 works)

1 Like

Debian 9 has a very old version of Prosody which will be a headache

1 Like

Got same problem. Clear installation of docker version, tried 3 times to be sure that everything is default and according to instructions. But exactly same problem.

Openjdk-8 on Debian 9 didn’t fix it, so I started over with Debian 10 and used default-jdk for Java. Oddly, I got the same client behavior as before. I made a quick glance at the logs and saw some of the same errors. Maybe not all the same ones.

Thanks for the tip. Is default-jdk the recommended package?

I’m not using docker, but maybe our problems have the same cause and docker doesn’t change it. Maybe the guide is just too out of date.

Are the installation address and the connection address same?
Do you use an IP address or an FQDN?

1 Like

If by installation address you mean the address given when prompted during jitsi-meet installation and by connection address you mean the address used on the clients to load the site, then yes.

FQDN.

Yes, @emrah is right, the fact that you can’t see yourself by clicking the video button could be an indication that your connection is not secure - a fact that you could check by looking at the URL bar to see if there is a green lock.

1 Like

I think I had the green lock with a good Let’s Encrypt cert. I was able to see myself in the preview in settings, just not in the call. The browser asked if I wanted to allow the site to use the camera. So I don’t think it was an SSL issue.

That’s how it was until the last re-install anyway. I’ve just now hit the weekly limit for reissue of Let’s Encrypt certs from starting over too many times without reusing certs. I’ll switch domains temporarily and try to reuse the new domain’s cert next time I start over (which I probably should’ve done all along).

I’ll also try switching back to nginx and see if that helps.

Could someone confirm if Debian 10’s default-jdk is a good Java package to use, or should I try a different package?

try java --show-version if it’s 11 or 8 should be good to go, it’s only the adoptjdk that has uncomon cert handling.

1 Like

I have many server which run with openjdk-11-jre-headless version 11.0.9.1+1-1~deb10u2 on Debian 10 Buster This is the default Java runtime (default-jre) for Debian

1 Like

@gpatel-fr @emrah

I had a successful test call. :smiley: Thanks for the help!

Looks like you were right about there being an issue with the address. I was sure I had the green lock before… *shrug*

@nicrame
Some of this might be helpful to you:

I took another look and found that I hadn’t edited /etc/hosts. I had thought that wasn’t important because that section is marked “optional” in the guide, and I was hoping the config wouldn’t depend on a static IP address.

There was also a place in the datacenter’s web interface where the hostname could be changed and that might have been mismatched at some point.

I tried several times and changed things back and forth some, so there might be other changes that helped. It’s late here, so I need to stop now.

I don’t expect this matters anymore:

java is version 11

When I installed default-jdk, it installed openjdk-11-jdk-headless and openjdk-11-jre-headless.
java --version said

openjdk 11.0.9.1 2020-openjdk 11.0.9.1 2020-11-04
OpenJDK Runtime Environment (build 11.0.9.1+1-post-Debian-1deb10u2)
OpenJDK 64-Bit Server VM (build 11.0.9.1+1-post-Debian-1deb10u2, mixed mode, sharing)11-04
OpenJDK Runtime Environment (build 11.0.9.1+1-post-Debian-1deb10u2)
OpenJDK 64-Bit Server VM (build 11.0.9.1+1-post-Debian-1deb10u2, mixed mode, sharing)

@jmr
In my case adding “ENABLE_XMPP_WEBSOCKET=0” into .env file was the solution. Then i deleted .jitsi-meet-cfg so it was recreated by starting docker jitsi again and it’s working now, even behind Apache reverse proxy

1 Like

This is setup at home with a DMZ and LAN with a Fortinet firewall between, but LAN > DMZ is unrestricted access. I also configured NAT from outside and successfully setup a conference with 2 internal and 2 external devices.