Can't build Jitsi-Meet Web

Hello There,
When I tried to build Jitsi-Meet Project ,
There is no Build folder created.


Node.js >= 12 and npm >= 6 are required

If you have simply installed nodejs and npm from your linux distribution then these two are quite likely of an old version, typically an error like the following was shown during the build:
npm ERR! node v8.10.0
npm ERR! npm v3.5.2

#in that case you will need to upgrade nodejs manually
curl -sL https://deb.nodesource.com/setup_12.x -o nodesource_setup.sh
cat nodesource_setup.sh
sudo bash nodesource_setup.sh
sudo apt install nodejs

#and then you need to upgrade npm to the latest version
sudo npm install -g npm@latest

#after that run according to the developement guide
npm install
make

npm install will print a lot of warnings (as I write this)
audited 83118 packages in 10.39s
3 packages are looking for funding
run npm fund for details
found 5216 vulnerabilities (2832 low, 6 moderate, 2376 high, 2 critical)
this is expected. upgrading all dependencies will break things, so use this configuration.

After the build is complete then the compiled version of the web interface is found in the libs folder.

We already have the latest version of both and we tried the instructions that you provided again , but it does not work

Your build have succeeded,

you can use the whole Jitsi-meet-v2 as root for your nginx installation by changing your config in /etc/nginx/sites-enabled/

alternatively you can copy all files from
Jitsi-meet-v2/libs/* into your /usr/share/jitsi-meet/libs/
and
Jitsi-meet-v2/ccs/* into your /usr/share/jitsi-meet/ccs/

We tried , the Build folder not found (bundles not generated) , please help.

you are looking at the wrong location:
Look closely at the mage you sent.

the last line show that build folder is deleted and that is normal.

the green line above is show that the compiled css is now found in
css/all.bundle.css

the cp, copy, lines show that the compiled lib-jitsi-meet.min.js is now found in libs/lib-jitsi-meet.min.js

and so on

thus what you are looking for is the css and the libs folder

In order to test this we did a simple change in one of the files in source and after compiling everything we copied the CSS file and the content of the libs folder to an existing vanilla installation of Jitsi meet and it is as though nothing happened, even after restarting Nginx

Check if you need to clear the web browser cache

We have already tried to open this from a different browser on a different machine in another part of the world :slight_smile: