Cannot set up Jibri on Ubuntu 16.04 server


#1

I am following the instructions here: https://github.com/jitsi/jibri on a 16.04 virtual machine running on the google cloud compute platform.

  • First make sure the ALSA loopback module is available. The extra modules (including ALSA loopback) can be installed on Ubuntu 16.04 using package name linux-image-extra-virtual -> done
  • Perform the following tasks as the root user
    • Set up the module to be loaded on boot: echo "snd-aloop" >> /etc/modules -> done
    • Load the module into the running kernel: modprobe snd-aloop -> modprobe: FATAL: Module snd-aloop not found in directory /lib/modules/4.15.0-1021-gcp

I cannot find any support on the internet for loading the loopback module, please advise how to install this.


#2

You need to use an older kernel, 4.4.0-116. Download kernel that and change boot via grub


#3

Thanks Kevin, but the 4.4 kernel was released 2 1/2 years ago. This really needs to work with the latest kernels, and it’s hard to mess with grub on a vm. Is there an equivalent to snd-aloop for 4.15?


#4

‘uname -a’ tells me I am running 4.15.0-1021-gcp
installed the linux-modules-extra-4.15.0-1021-gcp package and now I can enable the snd-aloop module ok.


#5

So I was able to complete the instructions (and used the excellent video here: https://www.youtube.com/watch?v=OHHoqKCjJ0E) but the live stream option is greyed out and when I start a recording it fails.

service jibri status (before test):

● jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-10-24 06:42:56 UTC; 92ms ago
 Main PID: 11391 (java)
    Tasks: 16 (limit: 4687)
   CGroup: /system.slice/jibri.service
           └─11391 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.
   
Oct 24 06:42:56 jibri-1 systemd[1]: Started Jibri Process.

jibri status (after test - failed recording):

● jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-10-24 06:43:02 UTC; 19s ago
  Process: 11544 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
 Main PID: 11544 (code=exited, status=1/FAILURE)

Oct 24 06:43:02 jibri-1 systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Oct 24 06:43:02 jibri-1 systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Oct 24 06:43:02 jibri-1 systemd[1]: Stopped Jibri Process.
Oct 24 06:43:02 jibri-1 systemd[1]: jibri.service: Start request repeated too quickly.
Oct 24 06:43:02 jibri-1 systemd[1]: jibri.service: Failed with result 'exit-code'.
Oct 24 06:43:02 jibri-1 systemd[1]: Failed to start Jibri Process.

#6

Hey @MattB98, do you have liveStreamingEnabled: true in the *-config.js? Disclaimer, I haven’t gotten this to work. Live stream is available for me but it’s not talking with Jibri. I don’t completely understand the hostnames and what needs to point to where.


#7

Yeah, that’s set to true. The video seems really helpful with the host names.


#8

how does jitsi know the address of the jibri server? I’ve not added the jibri server IP address anywhere on the jitsi server?


#9

Hi,

Can you check for the jibri-xorg service? Both jibri & jibri-xorg must be running.

Regards,
Abhijit


#10
● jibri-xorg.service - Jibri Xorg Process
   Loaded: loaded (/etc/systemd/system/jibri-xorg.service; disabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-10-27 07:01:19 UTC; 1min 46s ago
 Main PID: 2418 (Xorg)
    Tasks: 4 (limit: 4687)
   CGroup: /system.slice/jibri-xorg.service
           └─2418 /usr/lib/xorg/Xorg -nocursor -noreset +extension RANDR +extension RENDER -logfile /tmp/xorg.log -confi

Oct 27 07:01:19 jibri-1 Xorg[2418]: xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.
Oct 27 07:01:19 jibri-1 Xorg[2418]: Current version of pixman: 0.34.0
Oct 27 07:01:19 jibri-1 Xorg[2418]:         Before reporting problems, check http://wiki.x.org
Oct 27 07:01:19 jibri-1 Xorg[2418]:         to make sure that you have the latest version.
Oct 27 07:01:19 jibri-1 Xorg[2418]: Markers: (--) probed, (**) from config file, (==) default setting,
Oct 27 07:01:19 jibri-1 Xorg[2418]:         (++) from command line, (!!) notice, (II) informational,
Oct 27 07:01:19 jibri-1 Xorg[2418]:         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Oct 27 07:01:19 jibri-1 Xorg[2418]: (++) Log file: "/tmp/xorg.log", Time: Sat Oct 27 07:01:19 2018
Oct 27 07:01:19 jibri-1 Xorg[2418]: (++) Using config file: "/etc/jitsi/jibri/xorg-video-dummy.conf"
Oct 27 07:01:19 jibri-1 Xorg[2418]: (==) Using system config directory "/usr/share/X11/xorg.conf.d"

jibri-xorg is running. I noticed I had to start jibri on startup, but not jibri-xorg.


#11

Still trying to sort this and I cannot help go back to my comment above. Howe does jitsi know where jibri is?


#12

It is the other way around. Jibri knows where is the xmpp server, it connects to it in a special muc. Jicofo also knows the xmpp server and enters the same room where all jibris are connecting to, and that is the way jicofo finds out about all jibris that it can use.


#13

Ah, that makes much more sense, thank you!

So it seems the jibri service is failing to start:

sudo service jibri start
sudo service jibri status
● jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-11-11 07:52:19 UTC; 49ms ago
 Main PID: 12996 (java)
    Tasks: 10 (limit: 4687)
   CGroup: /system.slice/jibri.service
           └─12996 java -Djava.util.logging.config.file=/etc/jitsi/jibri/logging.properties -jar /opt/jitsi/jibri/jibri.

Nov 11 07:52:19 jibri-3 systemd[1]: Started Jibri Process.

sudo service jibri status
● jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2018-11-11 07:52:23 UTC; 4s ago
  Process: 13098 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
 Main PID: 13098 (code=exited, status=1/FAILURE)

Nov 11 07:52:23 jibri-3 systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Nov 11 07:52:23 jibri-3 systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Nov 11 07:52:23 jibri-3 systemd[1]: Stopped Jibri Process.
Nov 11 07:52:23 jibri-3 systemd[1]: jibri.service: Start request repeated too quickly.
Nov 11 07:52:23 jibri-3 systemd[1]: jibri.service: Failed with result 'exit-code'.
Nov 11 07:52:23 jibri-3 systemd[1]: Failed to start Jibri Process.

The Jibri log files don’t give me much to go on:
2018-11-11 07:51:05.774 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json


#14

Any suggestions on how I diagnose this?


#15

Hi @MattB98,

Do you have jibri-xorg running? If not, if stop the lightdm service as it occupies the X desktop which will also be used by jibri, with service lightdm stop and start the jibri-xorg. Make sure both jibri and jibri-xorg is running.

Regards,
Abhijit