Cannot see video or hear audio on self-hosted instance


I setup ‘Jitsi Meet’ at

Type of server: Google Compute Engine with public IP
Open ports: TCP - 80, 443, 4443 and UDP - 10000

I followed instructions from these two places:

  1. Github - Jitsi Meet - Jitsi Meet quick install
  2. Github - Jicofo - Secure domain

3 clients behind a home router could communicate well in room created at .
The same clients still could connect to my self-hosted instance but can neither hear nor see one another.

All this time there are no obvious failures reported in logs (/var/log/jitsi).
I am unable to see what the problem could be.

Any ideas? Please let me know if someone would like to join in a room to experience the issue live.


What do you see in the JS console logs in your browser?

Also have you done the advanced part of the quick install guide, about port forwarding and setting up jvb that is behind nat, if it is behind NAT, not sure how are google engines configured.

Thanks for responding @saghul. Here are the log captures when I started a call.

I’m unable to upload files, being a new user. Let me paste logs in another reply to you

@saghul Unable to paste the logs since it contains a bunch of https:// links. Being a new user I’m being prevented from having them.

@damencho I didn’t have to setup any port forwarding when I setup nginx on the same instance. So I’m assuming the port forwarding/NAT-specific rules do not apply to my case. Do they?

@saghul In addition to the image I uploaded above, please access the complete browser log here:

@damencho In Firefox, I entered about:webrtc (as informed from an error in browser JS console. Please see the other link in post above) and arrived at this information:

You need to setup private and public addresses as said in advanced configuration, your jvb is advertising only its private address:

a=candidate:1 1 tcp 2130706431 4443 typ host tcptype passive generation 0
a=candidate:2 1 udp 2130706431 10000 typ host generation 0

Love the logging! Thanks for jumping in quickly @damencho and @saghul. Audio & video work fine now.

Your setup instructions, video and for that matter, stable maintenance of APT repositories are appreciated. I just sent a PR adding my case as FAQ hoping to make the process further smooth for newcomers.

Thanks again

I got the same, I can see the page in two browsers but they don’t see the room… and I get some errors on the SC

1- [modules/UI/videolayout/SmallVideo.js] <g.w.updateView>: Unable to init avatar - no id

2.- Access blocked by CORS policy: Response to preflight request doesn’t pass access control check

could someone help me?


Please open a new discussion topic, this one is old, and looks unrelated.

Where should i run this command? when i run it in ubuntu terminal it error