Cannot See my server or upgrade cert

Hi,
I only use my server for occasional use but after a recent upgrade (Ubuntu 20.04 LTS) I get the following errors. I changed ISP a few months ago and am not sure if that is the problem but I have not chaned any configuration and not sure if I needed to do something!?

I have also pinged the ports and they worl but poining a browser at the site just hangs and does not give any errors.

I would be gratefulto a pointer to the likely cause of the problem.

Thanks

peter@cider123:~$ sudo certbot renew
[sudo] password for peter:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/cider123.duckdns.org.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for cider123.duckdns.org
Using the webroot path /usr/share/jitsi-meet for all unmatched domains.
Waiting for verification…
Challenge failed for domain cider123.duckdns.org
http-01 challenge for cider123.duckdns.org
Cleaning up challenges
Attempting to renew cert (cider123.duckdns.org) from /etc/letsencrypt/renewal/cider123.duckdns.org.conf produced an unexpected error: Some challenges have failed… Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/cider123.duckdns.org/fullchain.pem (failure)


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/cider123.duckdns.org/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cider123.duckdns.org
    Type: connection
    Detail: 78.33.99.154: Fetching

http://cider123.duckdns.org/.well-known/acme-challenge/JBEIC1arWWPRXMcYV3vPPZwFhBjjYxVPmcCqoCcGe8U:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.
peter@cider123:~$

peter@cider123:~$ sudo ufw status
[sudo] password for peter:
Status: active

To Action From


80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
4443/tcp ALLOW Anywhere
2222/tcp ALLOW Anywhere
22/tcp ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
4443/tcp (v6) ALLOW Anywhere (v6)
2222/tcp (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6)
22 (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)
8080/tcp (v6) ALLOW Anywhere (v6)

peter@cider123:~$ systemctl status nginx
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2022-04-29 13:07:54 UTC; 4h 57min ago
Docs: man:nginx(8)
Main PID: 1124 (nginx)
Tasks: 5 (limit: 9309)
Memory: 11.8M
CGroup: /system.slice/nginx.service
├─1124 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
├─1125 nginx: worker process
├─1126 nginx: worker process
├─1127 nginx: worker process
└─1128 nginx: worker process

Apr 29 13:07:43 cider123.duckdns.org systemd[1]: Starting A high performance web server and a reverse proxy server…
Apr 29 13:07:54 cider123.duckdns.org systemd[1]: Started A high performance web server and a reverse proxy server.
peter@cider123:~$

The first thing that you should check is that the IP address pointed by your dynamic DNS record is the one of your server of course.

If that’s not the problem, you need to investigate it by setting a file, let’s say yourfile (don’t need to amount to much, just type a letter in it) in the /etc/share/jitsi-meet/.well-known/acme-challenge directory and querying it from the outside of the network at http://yoururl/yourfile and verify that the file can be accessed. If not, you have to find from the web server logs what is happening.

Also, you don’t have a jitsi-meet problem, you have a certbot problem. The best place to get help about certbot is the Let’sEncrypt forum.

Thanks very much for your info.
My problem is almost certainly due to forgetting to change to the new IP address on the DDNS!
I will check and do as suggested and, if necessary, go to LetsEncrypt for further help.

Regards