Cannot open jitsi meet with public ip address

I install jitsi meet from

https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

and I setup domain with ip address 172.xx everything in local network is working fine.

when I setup behind nat.

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=172.xxx
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=193.xx

I cannot access webpage of jitsimeet by https://193.xxx but the local network is working fine yet.

I config NAT and forward Public IP 193.xx to 172.xx by Firewall in office.

What I missing config or setup for server please suggest for me. Thank you.

Hey I have the same problem have you find a resolution ? Thanks.

Assuming that you have a FQDN address,

  • enable the STUN_MAPPING_HARVESTER_ADDRESSES line
  • configure the NAT_HARVESTER lines according to your local network

The related file is /etc/jitsi/videobridge/sip-communicator.properties

No I don’t have an Fqdn adress, I have a public IP and a local IP behind Router! Yes I edited That file and added 2 lines as described


org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>
with my local and public Ip adress 192.168…, 82…
Where should I Enable STUN_MAPPING_HARVESTER_ADDRESSES. isn’t written in the installation guide ??
I found
" And comment the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES "
Thank you !